Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Firefox 3.6 - Navigation Toolbar - Google search box language problem

I am currently working from Germany. From Firefox, if I give something to search in the Google search box in the browser, it is automatically taking me to, and is returning results which is of no use for me.

Is there any chance, that I can change the default to or or, something like that which gives me English results?

share|improve this question

migrated from Feb 22 '10 at 9:20

This question came from our site for professional and enthusiast programmers.

marked as duplicate by ChrisF, fretje, quack quixote, Ivo Flipse Feb 22 '10 at 12:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Duplicate -… – ChrisF Feb 22 '10 at 9:31
up vote 4 down vote accepted

Search for any keyword using Firefox' builtin search box. It takes you to Now go to Google's homepage, and click on click in English in the footer. Next time you use the browser's search box, it will take you to

share|improve this answer
+1. It works. But how does it work? Using a cookie? It seems to be a setting per browser, not per computer. – Peter Mortensen Feb 22 '10 at 10:00
@Peter Mortensen: yes, it's cookie based. If you install a new Firefox search plugin, it will only effect a specific browser (a Firefox profile, to be precise). – Török Gábor Feb 22 '10 at 10:42

If you're using Firefox search box (on the right side of the address navigation bar), you can download other search engine plugins from here. Hope this helps!

share|improve this answer

You will find here instructions on how to change the default Google search used by Firefox.

It’s a very simple fix, basically all you need to do is navigate to the firefox directory (“c:\program files\mozilla firefox” is the default for windows) then open the “searchplugins” folder.

Next you need to edit the “google.xml” file and change this line:

<Url type=”text/html” method=”GET” template=””>


<Url type=”text/html” method=”GET” template=””> 

or whichever google locality you wish to use. I also changed this line (but i’m not sure if it’s necessary):


Then re-open firefox and search away!

share|improve this answer
+1 to counter the unjustified down vote. What is wrong with this answer? – Bryan Apr 3 '10 at 9:41

Not the answer you're looking for? Browse other questions tagged .