Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Windows 7 32bit machine I'm running a VirtualBox instance of Xubuntu 9.10 32bit and I've noticed that the screen saver on the virtual box instance of Xubuntu never becomes active despite setting the timeout to 1 minute.

I also have a Kubuntu 9.10 instance that I also run on VirtualBox on this machine and this does actually become idle and activate the screen saver, locking the session which is the thing that I am trying to achieve.

I'm wondering if there are any suggestions for things to either check or change to get the system to become idle (it's a very bare installation, pretty much just the bare installation and Google Chrome) or whether there is some other method that I could achieve the same effect (have the system lock after 1 minute of inactivity) without relying on the screen saver?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

ps x | grep xscreensaver will tell you if the screensaver is running. Just running xscreensaver in a terminal is enough to start it up, if not. The configuration which sets timeout and locking behavior etc. should be customized in $HOME/.xscreensaver

An alternate locking program is xlock.

Just to be clear: xscreensaver should be constantly running if you want your session to auto-lock - it is the program that detects that you have been idle, locks the screen, and displays the screensaver.

share|improve this answer
    
Justin, thanks for the response, I have the following running at the moment: "gnome-screensaver". I installed xscreensaver to see what would happen, but as I expected it complained that gnome-screensaver was already running. Presumably I should be able to de-activate the gnome-screensaver and use xscreensaver instead? –  Richard Feb 22 '10 at 15:31
    
Nice one, I noticed that I now have two entries in the "settings" panel, both called screensaver and clicking on the topmost one ran the xscreensaver GUI and prompted me to stop the gnome-screensaver demon. xscreensaver is now locking my screen as I would like. –  Richard Feb 22 '10 at 15:47
    
glad that worked for you - I was not aware that xubuntu came with gnome-screensaver, it should be possible to get gnome-screensaver locking properly as well, but it looks like xscreensaver is working better for you anway :) –  Justin Smith Feb 22 '10 at 16:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.