Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I plug any USB device into my computer while running Windows Media Player 12 in Windows 7, it will automatically swtich the player from the Now Playing mode to Library mode. This is intended to faciliate syncing between Media Player and MP3 players, but it happens for any USB device.

I'd like this to not happen since it's infuriating to see this take place while I'm watching something on a separate screen in Media Player just from plugging in a USB key.

This has nothing to do with Windows autorun, and nothing to do with versions of Windows pre-7.

And no, switching to some other video player is not an option; I've tried them all, none are as good as stock Media Player in 7.

share|improve this question
    
I get exactly the same problem with Media Player in Vista, if I plug my phone or PSP or whatever in to charge while I'm watching a movie it swaps to the library mode and offers to sync. Interested to hear if an answer to this question would work for me too. –  GAThrawn Oct 16 '09 at 10:25
add comment

3 Answers

According to this recent question Stop Windows Media Player showing synchronization dialogue when USB device plugged the trick is to let it partially sync so that you get the WMPInfo.xml file created on your device (and leave it there), you can then go into WMP's options and your device will be listed along with the options uncheck "Start sync when device connects".

The questioner was asking about WMP11 on XP, but I've confirmed that this also works with WMP11 on Vista. Haven't had a chance to try it on my Win7 machine at home yet, but it does look very likely to work.

share|improve this answer
add comment

Ever tried to set the Autorun settings for your USB device?

In Windows XP it would be like this:

How to Disable USB Drive to autorun (Windows XP):

  • Open Windows Explorer or press the Windows + “e” key.
  • Right-click the drive of the USB Drive.
  • Then select Properties. Drive Properties will appear.
  • Select the AutoPlay tab.
  • Choose Select an Action to Perform
  • At the bottom of the selection, click Take no Action, then click Apply.
  • Click OK to exit Drive Properties.

If you don't think that will work go to the Microsoft Knowledge Base It will help you tweak your register to disable Auto-Run completely for certain devices.

Type gpedit.msc in the Start Search box, and then press ENTER to open the Group Policy Editor.

Under Computer Configuration > expand Administrative Templates > expand Windows Components > click Autoplay Policies.

In the RHS Details pane, double-click Turn off Autoplay to open the Properties box. Click Enabled, and then select All drives in the Turn off Autoplay on box to disable Autorun on all drives.

Restart.

Additional Read:

How to selectively disable specific Autorun features and more on KB953252.

You can also open the Control Panel

Control Panel > Hardware and Sound > AutoPlay and set the options as per your preferences.

3) The same can be achieved by editing the Registry. Run regedit and navigate to:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

In the RHS, create a new dword and rename it to NoDriveTypeAutoRun.

Rt click on it and give it a decimal value 225 (or Hexadecimal value 000000FF) Exit regedit.

Reboot.

This will disable AutoRun on all drives

share|improve this answer
    
i suggested this and he bit my head off, watch out =O –  John T Jul 23 '09 at 6:24
    
Haha, Bite me :P –  Ivo Flipse Jul 23 '09 at 6:32
    
It's a Media Player 12 issue in 7, not a Windows issue. Changing the autorun has no effect -- it's the first thing I tried months ago when this started bugging me. This has nothing to do with Autorun, nor Windows XP for that matter -- WMP12 isn't even available on XP. –  matthews Jul 23 '09 at 14:17
    
You do understand that if it happens when you plug something in Auto-run is the first thing to suspect? Plus XP did have a different version of WMP which might have that problem –  Ivo Flipse Jul 23 '09 at 14:45
add comment

right click on playlist toolbar, go to tools, then click options. on player settings in player tab, click the 'keep Now Playing on top of other windows'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.