Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I booted up my box today after the weekend, and my apps no longer have the System Menu Bar at the top. It kinda sucks 'cause that's an easy way to maximize windows.

How do I get it back? And I'm not talking about the panels at the top/bottom of the screen. This is what my terminal looks like. It's really missing the bar at the top.

image

share|improve this question
    
Are you using compiz? (Desktop Effects) There's been an issue for a number of years with the window borders disappearing while using compiz. Try disabling your desktop effects. If that restores the borders, you may need to install a different window manager--I was forced to when I ran into the problem myself a couple of years ago. –  Emory Bell Feb 24 '10 at 0:19
add comment

3 Answers 3

It might be Compiz at fault. Press Alt+F2, and type metacity --replace. That will turn off Compiz, and may alleviate the problem. If it does, you can try clearing your compiz settings (delete .compiz in your home directory), or reinstalling compiz (sudo apt-get remove compiz && sudo apt-get install compiz).

share|improve this answer
add comment

One possible explanation is that the window manager is having problems, possibly not running at all.

share|improve this answer
    
i'm no linux guru, but wouldn't gnome not be functioning much at all if the window manager wasn't running. i can still open apps, switch between them and what not, I'm just missing the system toolbar on each window. –  user25522 Feb 22 '10 at 19:55
    
As I said, X might still be running but the window manager is borked. When it happened to me, all existing windows resumed their prior location, but any new ones were positioned top-left. Or, it could be something else - have you tried changing to a different window manager to see if that makes any difference? Any problems reported in any logs? –  chris Feb 22 '10 at 21:59
add comment

You can reset your gnome environment by deleting ~/.gnome2/.gnome directories and files. ~/.gconf has your configuration, however, so you may need to delete that as well to reset everything.

Granted, this is a nuke-everything approach, but generally I find that it's just not worth the effort to look through logs or examine every setting to fix an issue that can be fixed this way. I also find that the one time I did this, everything was much more snappier ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.