Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my office, I created and configured a virtual pc in Windows XP Mode. Everything was working fine.

Now I'm on the road, and my Internet access (in the host operation system) is either via a hotel wifi or through my Verizon air card.

Either way, I've lost Internet access in the virtual pc. I went into the Virtual PC settings, and set the Networking value to Shared Networking (NAT). Actually, I've tried every combination I can find, but I can't get from the virtual pc to the web.

I'm hoping to use the virtual box at a client site, so I really need that access. Is there anything I can do to get it back?

Thanks for any help.

share|improve this question

Enable the integration features in the Virtual XP settings: Go to All Programs, find Windows Virtual PC, click it and find XP mode, right-click it, choose settings, find Integration Features, and check it off. Check in VPC Settings that your "Network" include integration for your network adapter card. See, in this example it is set as Adapter 2. (In this case there was a wired and wireless network card present, your desktop will only have one network card)

Alternatively, to set auto-integrate just enable it in the "Integration Features" below "Networking" the Setting Window. OR from the XP mode window, click ACTION > Enable Integration Features. Image 1 Ok...since I'm a "new user" you don't get to see the image...sorry. I tried.

Image 2 Ditto. No image for you. Hope you figure it out anyway!

share|improve this answer

I have had problems with bridged mode on restricted/protected networks such as wifi hot spots simply because places such as Wifi hotspots usually use MAC address filtering, however, NAT mode usually fixes things.

If you are still having problems, I would check to make sure that you have got a dynamic IP set an not using fixed - followed by either typing IPCONFIG /RENEW and/or a full restart.

If this still doesn't fix things, it is time to do some diagnostics - I would check your wifi and 3g adapter to make sure that the Virtual PC driver has been loaded against it (possibly a repair install if it hasn't) followed by general network diagnostics - possibly try pinging the host, using a static IP in the correct range etc.

Please post feedback and I will try to help further.

share|improve this answer
Thanks for your answer. I've restarted the machine several times, with no results. Ipconfig release and renew just brings back the same settings (is something being cached somewhere?). I tried pinging the host and get nothing, which seems weird. I don't know how to check the virtual pc drivers, other than to look at the settings and see that they are there. – kousen Feb 23 '10 at 0:30
I would try a repair install. If you can't, simply go to network connections then view the properties of any adapter and see if you see Virtual PC Bridge/adapter or similar (can't remember exact name) in the list. It may have the same settings each time, - this isn't really a problem as long as they are correct. Check and make sure that the address doesn't start with 169. and if it does, try manually setting the ip to something in the same range as your host machine's virtual pc nat interface. If you post the host pc's nat settings - I can help/tell you what to put in guest. – William Hilsum Feb 23 '10 at 0:48
I found the problem. It wasn't the virtual machine, exactly, it was the host. When I connected to the hotel wifi, when it asked whether it should be "home", "work", or "public", I selected public automatically. Unfortunately, that meant the VM couldn't see the network connection, so it couldn't share it either. I switched it to public (I'll have to try work later), and after a reboot, now it's working again. Thanks for your help, though. That was very kind of you. Once again, this place just paid for the subscription. (Wait, it's free? Cool!) – kousen Feb 23 '10 at 3:20

As I mentioned in my comment above, the answer turned out to be changing the nature of the host network. On Win 7, whenever I join a network, it asks whether the new network is home, work, or public.

Normally I choose public, which means my computer can't see or be found by other computers on the same network. That includes, unfortunately, the virtual machines I'm running. By setting the network to "work" (or even "home", though that seems a bit extreme), the VM can share the network access and everything is fine.

share|improve this answer

For me, XP mode on Windows 7 was working just fine, then all of a sudden it wasn't.

Poked around a bit without much luck for a while. I could ping the host system from the VM, but I couldn't ping the default gateway, do DNS lookups, etc.

I can't see why this would matter, but I remembered that a while ago I had disabled IPv6 (don't need it on my home system, and just adds extra junk I don't care about to any WireShark captures I might make), so I tried re-enabling IPv6 on the host Windows 7 box, and then I booted up the XP mode VM, and everything was working fine again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .