Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was using Firefox 3.5 when this happened.

I tried the obvious workarounds: Upgrade to 3.6. Downgrade to 3.0. None worked.

I'm using Windows Vista 64-bit.

The only extensions installed are Lori, Roboform, Google Toolbar, Live HTTP Headers, Skype, and Yahoo Toolbar -- all of which I have used for a very long time with no problems.

share|improve this question

6 Answers 6

You may have a locked or damaged places.sqlite file. Beginning with Firefox 3, bookmarks and browsing history are stored in the places.sqlite file. If the file can't be updated with your browsing history, the browser has nothing to go forward or back to, hence the disabled buttons which look as if you just started the browser. Having the back and forward buttons disabled is a common symptom of a locked or damaged places.sqlite, so that's where I'd check first. See the MozillaZine article, Locked or damaged places.sqlite.

share|improve this answer

If John's response doesn't work for you it may be worth starting a new profile. You'll have to redo your settings and copy over your bookmarks but it should work.

share|improve this answer
3  
If you choose this method, here is another great MozillaZine article that outlines how to transfer your settings to a new profile: kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox –  John T Feb 23 '10 at 16:55
    
very informative, thanks –  Burton Feb 23 '10 at 17:11

stumbled across this while I was having the same problem: back, forward, reload buttons all grayed out; menu bar became grayed out after the first time it was opened (or right click > "customize.." box was opened). None of the fixes worked for me but I found one thing that did. Though this thread is nearly a year old, I thought I'd post just in case someone else found this page and the fixes here didn't help.

Disabling Yahoo! Toolbar from my add-ons (Tools > Add-ons) and restarting Firefox brought everything back to the way it used to be. I haven't tried to reinstall the toolbar because I don't really care about it. Not sure if this problem is specific to Yahoo!Toolbar or if another add-on could cause the problem for others. Try disabling all of your add-ons and restarting firefox. If the problem seems fixed, it is likely one of them. You can then enable them one at a time (restarting firefox after each) to find out which one is doing it.

share|improve this answer

Disabling the Ubuntu Planet appearance add-on fixed my dimmed forward reverse buttons. Found under Tools, add-ons, appearance, then disable Ubuntu Planet.

share|improve this answer

I cannot find places.sqlite file anywhere. I know how to search for a file, but to no avail. Running Windows 7, 64-bit not that that should make any difference.

share|improve this answer

You can locate the file by using the instructions below:

Copied from: http://kb.mozillazine.org/Profile_folder_-_Firefox#Windows_Vista_and_Windows_7

Click the Start button on the Windows taskbar to open the Windows Start menu. In the "Start Search" or "Search programs and files" box, type in: %APPDATA%\Mozilla\Firefox\Profiles Click on any of the profiles (e.g., xxxxxxxx.default) to open it with Windows Explorer. You can also navigate directly to your profile folder at the following path: C:\Users\\AppData\Roaming\Mozilla\Firefox\Profiles\. The AppData folder is a hidden folder; to show hidden folders, open a Windows Explorer window and choose "Organize → Folder and Search Options → Folder Options → View (tab) → Show hidden files and folders".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.