Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows Vista system whose profile seems to have been corrupted. Many solutions seem to indicate that you create another admin account, log in as that account, and delete the offending profile information for the account that is corrupted.

Here's the twist:

There are two accounts on this System - 1. Administrator Account 2. Standard Account.

It's the Administrator Account which has become corrupted. If you attempted to do any user managment / attempt to create a new account under the 'Standard Account', UAC prompts for a user/pass. It has the admin account come up by default, and asking for a password (of which, there is none).

When you click 'OK' - nothing happens (no doubt due to the fact that the account is corrupted, so it can't verify who or what is trying to allow the administrative privilage).

Can anyone think of a way of fixing this account, or creating another administrator account to resolve this issue?

Many thanks in advance.

share|improve this question

migrated from serverfault.com Feb 23 '10 at 11:43

This question came from our site for professional system and network administrators.

3 Answers 3

I would try logging in to Safe Mode and activating the Administrator account first.

net user administrator /active:yes

net user administrator *new_password*

share|improve this answer

I would suggest reinstalling Windows Vista from scratch because a corrupted Administrator account messes with the whole computer...not a good place to be. If you do an in place upgrade to Win7, that could fix your issue, not 100% sure.

share|improve this answer

I just had the same issue. After failing to update java from my main account I thought, "Well, maybe this is one of the programs that doesn't work under UAC" and tried to log in as the administrator account for the first time in months. Vista said that the profile could not be loaded and returned to the login screen.

My problem was fixed by restarting the computer in safe mode. The admin account was then available. Oh, it complained about a damaged profile and said it was using a default one, but it still let me log in. And then I was able to get into the users control panel, create another adminstrator user, and even delete the existing administrator's profile since there was nothing in it I needed to keep.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.