Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I install the Ubuntu 9.04 my old Lenovo Y520 laptop, the wirless does not work.My Wireless card is Intel Pro/wireless 2100 card. But I can not enable it. My wired card is working well. Does anyone meet it before.

the ifconfig output is

eth0      Link encap:Ethernet  HWaddr 00:0a:e4:5f:6c:30  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:973 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1025 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:574701 (574.7 KB)  TX bytes:169249 (169.2 KB)
          Interrupt:10 

eth1      Link encap:Ethernet  HWaddr 00:0c:f1:58:79:b5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:10 Base address:0x8000 Memory:d0202000-d0202fff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)

the output of iwconfig is

eth1      unassociated  ESSID:off/any  Nickname:"ipw2100"
          Mode:Managed  Channel=0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I have another question. When my OS is 9.04, there is a icon about network connection on the panel at the top. After I upgraded to 9.10, that icon disappeared. How can I get that back?

Best Regareds,

share|improve this question
    
What does not work? Could you please post the output of ifconfig, iwconfig? –  Bobby Feb 23 '10 at 14:50
    
you might want to check ubuntu forums,I'm sure they can help you with your wireless problems –  Mahmoud Hossam Feb 23 '10 at 15:23
    
So are you running 9.04 or 9.10 now? –  Nathaniel Feb 23 '10 at 19:17
    
At first I install the 9.04,then Upgrade it to 9.10. –  Yongwei Xing Feb 24 '10 at 1:34

1 Answer 1

You probably need the Intel Wireless Firmware. Intel used to be pretty draconian about distributing it unless you did accepted the click-through license on Intel's website. This may have changed, but I forget when.

(It's why I went with Realtek & Ralink chipsets.)

it goes in /bin/firmware I think.

You can find the Intel Firmware here: http://ipw2100.sourceforge.net/firmware.php

share|improve this answer
    
Do you mean I need run the firmware?Sorry I do not quite catch you. –  Yongwei Xing Feb 23 '10 at 16:33
    
No. The driver will load the firmware. You just need to have it present. –  Broam Feb 23 '10 at 20:34
    
so, what should I do now? I am new for it –  Yongwei Xing Feb 24 '10 at 1:34
    
ipw2100.sourceforge.net/firmware.php –  Broam Feb 26 '10 at 15:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.