Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 Ultimate 64 bit on a Dell Vostro 1720 with 8GB of RAM, 7200RPM Disk, 2.53 GHz Core2Duo (Windows 7 64 bit is a supported option and the laptop came with the OS pre-installed).

I'm noticing some fairly excessive disk activity when running installers. For example the Visual Studio 2010 RC installer constantly accessed the disk for ~10 minutes. It was so excessive that I was unable to use the machine until this ceased.

Today I installed Trillian Astra 4.1 for Windows (latest build from the website). Again when I ran the installer I was pretty much locked out of the machine until the disk activity calmed down.

In both cases when I eventually managed to launch task manager I could see that the CPU was sitting at around 5% to 7% utilisation whilst this was going on.

All other disk related activity is fine, the machine is snappy and applications launch without delay. It's just when I run an installer I see this odd behaviour.

Why would this be?

share|improve this question

3 Answers 3

up vote -1 down vote accepted

The problem has spread, IE wouldn't launch properly today and would cause the disk activity indicator to light up permanently. Now seeing disk controller errors and NTFS complaining about IO failures in the event log. So I'm guessing I'll be calling Dell tomorrow for a replacement.

Dell technician ran me throught the onboard diagnostics, disk fault was picked up right away. New drive shipped and fitted.

share|improve this answer
    
Why the downvote? This is the correct answer even if it's my own –  Kev Mar 11 '10 at 15:37

I don't know about Trillian, but Visual Studio will be writing a lot of files to the hard drive. I won't be a CPU intensive activity, but will obviously be a disk access intensive activity. If a significant number of those are quite small then I can see it "taking over".

What happens if you copy a relatively large number of small files? Do you get the same pattern of activity?

UPDATE

If you say it happens before the file write phase, I wonder if it's when the installer is identifying where to write the files. Is your hard drive getting full or is it particularly fragmented? If the installer is having to find lots of widely separated file blocks to write to that might explain the problem. You could try defragmenting the drive and see if that improves things.

share|improve this answer
    
The issue starts happening before the installer starts writing files. It's like it's doing some kind of scan of the disk to gather info about how the machine is configured. The actual writing of files once the installer is going is fine and doesn't lock the machine. It's just whatever initial stage the installer goes through that causes this problem. I know VS will be writing hundreds, if not thousands of files but this is new behaviour. –  Kev Feb 24 '10 at 1:06
    
@Kev - I did wonder if it's your anti-virus software, but that wouldn't kick in on the file read. –  ChrisF Feb 24 '10 at 9:15
    
@Chris - it's a brand new laptop, the disk is practically virginal and has loads of contiguous free disk space. Uninstalling AVG didn't help. It's maybe the sort of thing I'd expect from a heavily fragged disk, but even then I've never seen the disk I/O such that you can't even ctrl-alt-del to get the task manager or click the start menu. I might flatten it and start again. –  Kev Feb 24 '10 at 15:14
    
@Kev - In that case I'm stumped too. –  ChrisF Feb 24 '10 at 15:28
    
@Chris - yeah, me too. Think I might flatten it and start again, if it does the same it could be an indicator of an underlying hardware fault about to go hard so may as well find out now while before I start using it in anger. Thanks anyway. –  Kev Feb 25 '10 at 16:16

This sort of activity is normal with many installers and I wouldn't worry about hard drive activity.

However, I would be worried about not being able to do anything else whilst this is going on.

If you are using a 5400RPM drive, I would upgrade to either 7200RPM or SSD, if you however are using a 7200RPM drive, check in device manager that it is in DMA mode (Expand controllers, and take a look there - if you need any more help on this, please say).

Next, If you are still having issues, the only other time I have seen this is when you have a faulty / bad antivirus that interfears or is overly sensitive. Try disabling it and/or saying what you have and again, I will try to help further.

Lastly, in case it isn't just the installer par se, take a look at Microsoft / Sysinternals Process Explorer, and click on the activity graph at the top, then you should be able to look at any of the peaks under Disk I/O to see what is causing high hard drive usage.

I hope that this pushes you in the right direction.

share|improve this answer
    
Yes, the HDD is often the bottleneck for most computers most of the time (other than the network of course), which is why SSDs offer such a noticeable improvement: anandtech.com/storage/showdoc.aspx?i=3631&p=20. Also, defragmenting the HDD may be worth a shot. –  sblair Feb 23 '10 at 21:59
    
The machine has a 7200rpm disk and a 2.53GHz Core2Duo processor, so it's no slouch. I'm well aware of how busy installers can get, but this is new behaviour, it never did this before. I did try disabling AVG (which is usually pretty non-invasive) but no joy. This problem seems specific to installers, all other disk intensive activity doesn't affect the machine this way. –  Kev Feb 24 '10 at 1:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.