Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed mplayer with this ppa and smplayer with this one. I put the following in my ~.mplayer/config:


Now, mplayer works like a charm and vdpau is working, my cpu never goes above 6%. So I figured smplayer would be a nice gui for mplayer, and figured it would play the video the same way mplayer would (since it's just a frontend) but I get no video at all. What am I missing here? Do I need to do something different to get smplayer to play my mkv's?

share|improve this question
If you look at the output of ps x, what is the mplayer command that smplayer is running? – user23307 Feb 23 '10 at 23:21
thanks for that tip, it was running with vo=vx. Sunny's suggestion worked, I had to tell smplayer to run with the vdpau driver – Brad Robertson Feb 24 '10 at 15:07
up vote 0 down vote accepted

You need to set the proper options in smplayer. If you not see them in the GUI, then, in the Advanced section you can add arbitrary options to be passed to mplayer.

share|improve this answer
I guess I just assumed it would take my .mplayer config, obviously not. Adjusting the video driver from vx do vdpau worked! Thanks a bunch! – Brad Robertson Feb 24 '10 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .