Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I am using Komodo edit, and it thinks that my current directory is /home/username1/ Yet my files are in /home/username1/workspaces/ruby/project1

Why won't Komodo recognize that my working directy is that of the current file? Same with situation when I use Komodo Edit to launch a command ("ruby [complete path+file name]"), ruby can't find its require dependencies unless I give a complete path because it too seems to think it is working out of /home/username1/

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

From here: http://community.activestate.com/faq/komodo-file-locations

You can use a completely custom Komodo user data directory by setting the KOMODO_USERDATADIR environment variable. I.e. export KOMODO_USERDATADIR=/tmp/komodoide51

You can use similar approach with ruby - look in the ENVIRONMENT section in the man file: http://linux.die.net/man/1/ruby

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.