Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The question is easy to answer I guess. (Tried to search here, didn't find an answer.) So.

The deal: There is a bug in OpenOffice (haha ..just one? :)), which prevents the spellcheck. You have to start it with right-click , run as administrator to make it work.

Tried also setting this at the 'properties', but it didn't work. But 'quickstart.exe' would be also enough to make this work. (OpenOffice's quickstarter). So I'd like to run it at boot, as an admin, like I'd do with right-click. How to do THAT?

(Actually there is a different bug for spellcheck on Win7. One have to run oowriter.exe as an admin, and then install the extension BY HAND from Program Files...\share...*.oxt. And THEN it'll work IF you run the app as an admin. (I'll buy SoftMaker's office as soon as the hu spellcheck arrives, but until then I have to make this work. Thanks for the answers in advance.))

share|improve this question
Okay.. just installed SoftMaker office. It works perfectly, better than MS Office or OpenOffice. :) – Shiki Apr 6 '10 at 4:30
up vote 1 down vote accepted

Create a RunAs batch file and place a shortcut in your startup folder.

share|improve this answer
Nice one. But how to configure it up? Read the whole document, but it asks for Admin pw.. which is obviously not set on Win7. What to do ? I don't really want to enable my admin account, nor set a pw on it. – Shiki Feb 24 '10 at 19:15
Do the RunAs under your account. It has admin privs. – Justin Drury Feb 25 '10 at 21:09
@Fujishiro - that's right, any account with admin privileges should do, doesn't have to be the built-in admin account. – Molly7244 Feb 25 '10 at 21:31
Yeah..but..uhm.. how to param it up to use the admin priv? It asks for password. Sorry for being so lame.. :)) – Shiki Feb 26 '10 at 6:28

You could just go into properties -> Compatablility -> Run as Administrator. This will mean you never have to right click -> Run as Administrator ever again.

share|improve this answer
Thats what I did, and thats what wont work. Even if I do the for all users part. No effect like this. Strange, but this happens. – Shiki Feb 24 '10 at 15:40
You can try doing the same for the quickstarter shortcut. – Justin Drury Feb 24 '10 at 16:02
Tried, sadly no use. – Shiki Feb 25 '10 at 16:11
Enable the built-in administrator account (disabled by default) and you should be ok. The only other thing I could see being a problem is the group policy: UAC: Admin Approval Mode For The Built-In Administrator Account (disabled by default which is what you want but check it to be sure) – SnOrfus May 22 '10 at 7:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .