Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I Have a NextStar 2/5" from Vantec and its an 80G HD. I have used it many times on windows xp and it works fine. We just recently upgraded to windows 7 home premium and when I plug it in it beeps many times. I've tried all the USB plugs in my computer and its not those plugs. Haven't tried eSata because it uses a weird cable to plug into. People told me that when it beeps everything is corrupted, but works fine on xp. I tried installing the drivers online from their website and when I try it asks me to put in a cd which makes no sense because they are online drivers. When I go into device manager nothing comes up, it just acts like the HD is invisible. The beeping will stop eventually as it is plugged in, but with no result.

share|improve this question

2 Answers 2

No idea if this is your problem. I posted this to a forum some years ago but have no idea if it is applicable to Windows 7.

Microsoft and Dell deliberately and secretly disable dynamic disk support on Windows XP Professional for laptops! Betcha didn't know that.. turns out Dell Support doesn't know that either!

Microsoft detail this deliberate sabotage in the following article: http://support.microsoft.com/kb/232463/EN-US

The fix, on my Inspiron 710m, is to change the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dmload\Start to 0 (zero) from the number 4 (four) as it was before on my laptop.

A reboot is required after the registry change is made.
share|improve this answer

Does the disk show up in the disk manager? I've had problems on all versions of windows where it sees the dis but doesn't allocate it a drive letter.

share|improve this answer
    
Start --> Run --> diskmgmt.msc –  quickcel Feb 24 '10 at 17:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.