Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just replaced XP with Server 2008 R2 on my test sever, and have been running 2008 R2 on my dev laptop. When my server was still XP, file sharing just worked, but now it just doesn't. I've enabled everything I can about sharing, and I can ping the server by machine name, but if I try an access a share, I get asked for a password. The passowrd dialog assumes a domain for this user, but neither my laptop admin user nor my server admin user can get past this login. What am I doing wrong?

share|improve this question
add comment

2 Answers

Windows XP uses "guest only" file sharing, user accessing your file sharing will not be prompted for password. This kind of sharing although is convenience but introduce a dangerous security loopholes. In Windows Server 2003/2008, guest account is disabled and by default everything is disabled. You have to set NTFS, create share permission and more... Good luck.

share|improve this answer
    
Plus, think about Windows firewall blocking share ports. –  djangofan Dec 2 '11 at 0:24
add comment

Have you set permissions for the share and NTFS permissions on the folder/files?

The fact that it is prompting you, means its probably working fine, just a perms/settings conflict.

The "standard practice" if you like, is to allow full access to "domain users" in the sharing, and selective permissions on the actual NTFS objects for more granular control. (Like some users no access to certain folders, others read only, others read/write, others append only etc.. you just can't do that with the sharing tool, but you can with NTFS, and you can use groups!)

If you can't get it, you can always enable auditing, it will quickly fill your security event logs with who/why.

Also, if you try several times, your account may get locked out, so check that too!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.