Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used the instructions on this webpage to create a bootable USB drive for running Ubuntu 9.10. Unfortunately it doesn't work on my Eee PC.

Even with 'Removable Dev.' selected in the BIOS as the first boot device, the PC just boots into Windows 7.

How do I troubleshoot this problem?

The drive is readable and looks like this:

 Directory of E:\

28/10/2009  21:14    <DIR>          .disk
28/10/2009  21:14               222 README.diskdefines
28/10/2009  21:14               143 autorun.inf
28/10/2009  21:14    <DIR>          casper
28/10/2009  21:14    <DIR>          dists
28/10/2009  21:14    <DIR>          install
28/10/2009  21:14    <DIR>          syslinux
28/10/2009  21:14             4,098 md5sum.txt
28/10/2009  21:14    <DIR>          pics
28/10/2009  21:14    <DIR>          pool
28/10/2009  21:14    <DIR>          preseed
28/10/2009  21:14                 0 ubuntu
26/10/2009  16:16         1,468,640 wubi.exe
25/02/2010  00:28     2,147,483,648 casper-rw
               8 Dir(s)   5,290,307,584 bytes free
share|improve this question
up vote 4 down vote accepted

The problem was that 'removable dev' doesn't mean 'USB drive' (I'm not sure what it is, can't think of any other removable devices that I could connect to this Eee PC...)

As a result, putting 'removable dev' at the top of the boot device list didn't work.

When searching through the boot options again, I went into the 'Hard Drives' menu and found USB in this list. When I moved USB to the top of the hard drives list, the Eee PC booted successfully into the Ubuntu boot menu! You can't prioritise HDDs in the main list, they're delegated to this other priority list. When I changed the Hard Drives list, the main list changed to show USB in place of my HDD's name (NB: without a USB drive plugged in, the PC boots from HDD.)

So, for some reason the Eee PC BIOS thinks of USB drives as hard drives. Well, I guess they're not floppies...

Incidentally, I can't believe how good Ubuntu is compared to my previous experiences of Linux. Really slick. (So far at least).

share|improve this answer
I can boot of a memory card on my EEE901 if I select "removable device" in the bios. – Nifle Feb 25 '10 at 10:14
Ah, that'll be it then. – mackenir Feb 25 '10 at 16:54

You may have to rearrange the boot order in the BIOS to set it to search for removable media before the main hard drive.

share|improve this answer

Verify your USB drive on another machine. I suspect something went wrong during the creation process. If you're looking for an easy way to create boot disks in the future (especially after you have Ubuntu installed ), try the USB Boot disk creator in 9.10.

share|improve this answer

Ah. Those instructions are for making a bootable CD not USB. Difference there.

Lookup unetbootin

ps: Have you tried running wubi (I see it on the file list there). It's not what you want... but quite cute anyway!

share|improve this answer
Don't use Wubi. It breaks easily. For example the current Wubi has a different version of grub - the first time you do a software update you will get the new version of grub, and Wubi will no longer be able to boot. – Justin Smith Feb 25 '10 at 22:33

After your Eee has booted, can it read the USB stick at all? I tried exactly the same thing a few weeks back, but found that my (Linux) Eee thought that the USB stick was unformatted - which kind of explains why it wouldn't boot from it. I've been travelling, so I haven't had a chance to follow up on that yet.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .