Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a fresh install of Ubuntu 9.10 (64 bit) and for some reason the Google search field in the Firefox toolbar always searches google.jp. Given that I'm in Australia and struggle to read Japanese this is somewhat less than useful to me. Does anyone know how I can change the language/Google site that search field uses?

share|improve this question

4 Answers 4

This Firefox add-on will force the Google search to use the US .com server... At least it's a language you speak.

share|improve this answer

go to about:config and check if there is anything funky (like including japanese at a high priority) in intl.accept_languages

you might also play with intl.locale.matchOS

failing that, filter about:config for "google" and check for oddball settings in parameters.

share|improve this answer

The Mycroft Project is a huge collection of search plugins. You can add any regional/language based searches to your own collection, and delete the ones which you don't need.

For example I have Google Maps US, and Google Maps UK, and I move them up or down depending on where I am. I also have Google Images with no filtering, Rotten Tomatoes and YouTube.

share|improve this answer

Does the same thing happen when you navigate to http://google.com/? If so, Google may have your IP address wrong. Ask them to fix it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.