Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded to Firefox 3.6 and all of a sudden, clicking on links within email messages open in the same window. They used to open in a new tab using Firefox. In fact, this is still the case when using Chrome or IE7.

I can't find any settings that might be causing this behavior. I even looked at my add ins and extensions.

Thoughts?

share|improve this question
2  
This question is computer related. The issue is related to his Firefox, not to GMail in particular. Voting to reopen. –  Gnoupi Feb 26 '10 at 8:37
    
Question re-opened. I agree with Gnoupi that this is a firefox issue and gmail just happens to be what he is using within it. –  Troggy Feb 26 '10 at 9:30
    
So does it still happen with a blank profile and extensions disabled? –  njd Feb 26 '10 at 15:39
add comment

4 Answers

Works for me in Firefox 3.6.
The links in my GMail emails (which are displayed in HTML of course) are like

<href="http://..." target="_blank">

...and the target="_blank"means they should be opening in a new tab or a new window.
Possibly you have some extension which is changing the way this works.

Try running Firefox without extensions

firefox.exe -safe-mode

or with a completely new profile

firefox.exe -P some_new_profile

and see if the problem still occurs.

share|improve this answer
add comment

Using Firefox here, just notice if I right-click an email I wish to reply to and then choose "Send link..." from the contextual menu, it opens the email in a new tab. Not as easy as it could be, but functional.

share|improve this answer
add comment

I had been suffering from the same problem. Toying around with plugins, I realize that the 'Tabs open relative' plugin, which had to be manually installed in earlier versions of Firefox (but now seems to be there by default) is the culprit.

Disabling it, fixes the problem and all links marked with

{target="_blank"} 

(including the ones on GMail) do open in new tab/window.

share|improve this answer
add comment

Go to Preferences->Applications, and find the mailto Content Type. Change this to an application that changes the tab behavior.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.