Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my disk has over 100GB of free space, but the usage bar in Computer is displayed in red, as if it reached a low space limit. It looks like Windows applies the same 10% or 15% hard disk space value for low space warnings, regardless of if the disk is 50GB in size or 1.5TB, which is not very smart and obsolete for most recent computers.

Is there a Registry key or some place I can change this percentage so the usage bar displays in green, not red?

The hibernation and page files are already reserved (5GB together), so surely the low space warning for a 1.5TB disk should be 5-10GB, not 150GB or more. The way Windows 7 computes the low space limit seems pretty dumb, not much Intellisense there.

This is not a high priority issue, but it makes the Computer applet look pretty stupid and it's irritating every day to see that 100GB of free space is putting my computer in the red. It would also be nice to be able to edit this low limit percentage in Computer/Manage/Storage/Disk Management or directly in the disk properties ("Tools" tab).

share|improve this question

5 Answers 5

up vote 9 down vote accepted

There is literally the same question on Microsoft Answers (I guess you asked it there too) and the answer of Swathi B (Microsoft Support Moderator):

This is by architecture; unfortunately there is no option to change the percentage for the low space warnings on the computer.

You may provide the feedback about adding any new feature to the Operating System on the link: http://connect.microsoft.com

share|improve this answer

Found your exact question on the microsoft answers site, and it's not possible: http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/b42d61fd-9f5b-41d3-939a-83724aabab71

Would be nice to see it in a newer version of Windows.

share|improve this answer

The hibernation and page files are already reserved (5GB together), so surely the low space warning for a 1.5TB disk should be 5-10GB, not 150GB or more.

The ways relatively intelligent filesystems try to reduce file fragmentation as new files are created and old ones extended can backfire badly when space is low because the space that is left becomes very fragmented, so by the time you are down to 10Gb that could be lots of blocks no more than a few blocks in size.

So while 10% might be over doing it for large drives for most uses, letting a filesystem get to 1% before warning could cause noticeable inefficiency.

share|improve this answer

You can't change the percentage because it's hardcoded. Well, just get rid of those bars and voila - problem solved.

Source

  1. Run regedit.exe as administrator
  2. Open HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Drive
  3. Change the values for both TileInfo and PreviewDetails keys by removing the phrase "System.PercentFull;" (without the quotes)

    TileInfo key before and after

    prop:*System.PercentFull;System.Computer.DecoratedFreeSpace;System.Volume.FileSystem
    prop:*System.Computer.DecoratedFreeSpace;System.Volume.FileSystem
    

    PreviewDetails key before and after

    prop:*System.PercentFull;System.FreeSpace;System.Capacity;System.Volume.FileSystem;*System.Volume.BitLockerProtection
    prop:*System.FreeSpace;System.Capacity;System.Volume.FileSystem;*System.Volume.BitLockerProtection
    
  4. Open My Computer. You should be able to see the absence of the color bars. If you still see them, just restart Windows Explorer or Windows itself.

share|improve this answer

The Following worked me. Hope it works for you.

Copy the following lines and paste them into a text file. Change the extension from .txt to .reg. Double-click (single click) the file to merge the contents into registry. After you restart or log off-log back on, you will not get the warning, hopefully. The registry change will force Windows to not check the remaining space on the hard disk.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoLowDiskSpaceChecks"=dword:00000001
share|improve this answer
1  
OP asked how to change the warning threshold, not how to disable it entirely. –  gronostaj Aug 2 '13 at 18:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.