Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I first noticed this when I tried a RDP to wxp-38-shop and it connected me to the computer wxp-alvinm

As you can see in the picture I pinged wxp-38-shop and it shows a different IP then whats given in the Address Leases page (w2k3 server). I tried to do ipconfig /flushdns on the server as well as the client computer, but it didn't update that way. If I do an ipconfig on wxp-38-shop is also shows 192.168.0.153, so why when I ping it from any other computer why would it be showing the wrong IP?

Picture Attachment

share|improve this question
    
I just noticed this is also causing Event ID 4 to appear in the log of the server: The kerberos client received a KRB_AP_ERR_MODIFIED error from the server WXP-ALVINM$. The target name used was cifs/WXP-38-SHOP.MacMachine.local. This indicates that the password used to encrypt the kerberos service ticket is different than that on the target server. Commonly, this is due to identically named machine accounts in the target realm (MACMACHINE.LOCAL), and the client realm. Please contact your system administrator. –  Bobby Mar 1 '10 at 18:55

2 Answers 2

Have you tried ipconfig /release and ipconfig /refresh on the clients? This forces the client to request a new IP lease from the DHCP server.

share|improve this answer
    
Yes I have tried the release and refresh. I confirmed from the computer that it did infact obtain a new IP, but when I ping that computer's name (wxp-38-shop) from the server, or any other computer it still shows as the old invalid IP. Of course the ping results time out because that IP no longer exists. –  Bobby Feb 26 '10 at 17:11
    
Then you should /flushdns on the computer you're trying the ping from, as this computer is keeping an old record of the hostname/ip combination. –  Roald van Doorn Feb 26 '10 at 20:15
    
You are right it does seem to be my computer that's keeping the old records. The strange thing is the server that assigns the DHCP addresses is also pinging the wrong IP address. Even though in DHCP Address Leases its showing the proper IP. I tried /flushdns on all computers (mine, the client, and the server) and I get the same results when pinging that computer. –  Bobby Mar 1 '10 at 16:27

Delete that IP Id from the Address lease. Restart the DHCP server and then your PC which is set to automatic detect IP Id in the LAN setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.