Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old IDE hard drive that has a broken Windows install on it. It just won't boot up, and I've tried a variety of solutions. That's fine, I really just need a few files on the hard drive.

I have a computer that uses a SATA connected hard drive. It's a working PC. I would like to connect the old IDE hard drive to that compute and basically browse through the file system, grab the files, and copy them to my existing computer.

My problem is with my few attempts to connect the IDE drive I would get Boot Disk Failures and so forth. I guess it's trying to boot from the IDE but I'm not really sure.

Any help would be appreciated, Thanks!

share|improve this question

migrated from serverfault.com Feb 26 '10 at 15:51

This question came from our site for system and network administrators.

4 Answers 4

up vote 6 down vote accepted

Your BIOS should have a boot menu. From there you can toggle boot order across a myriad of devices (IDE, SATA, USB, removable media, etc). Just make sure the drive you WANT to boot from is higher in priority to the wonky IDE drive.

share|improve this answer

Is the drive detected in the BIOS? If not, you may have an issue with the disk to work through. If so, be certain that your OS drive has priority in boot order.

An IDE to USB adapter is handy to have around.

Probably belongs on superuser.

share|improve this answer
    
The drives are both detected. I have no idea where to set Boot Priority for a particular HD .. my BIOS just gives me the "Hard Drive" option and nothing more. That's where I got kind of lost :/ –  Bartek Feb 26 '10 at 15:48
1  
+1 for IDE to USB adapter. Forget attaching this disk to the motherboard with the booting issues and that BIOS. –  p.campbell Feb 26 '10 at 16:21

SATA doesn't have any sort of specified boot order; windows starts with SATA 0 and keeps going until it finds a bootable drive. IDE, on the other hand has jumper settings that mandate boot order, so that could be what's causing your problem.

Does the IDE have any jumper settings that would force it into a MASTER configuration? Or is it set to cable select (which might be just as bad). I'd try shifting the jumpers to force it into SLAVE, and see what happens.

share|improve this answer

I was dealing with the same problems on Windows XP.

I just booted the computer with the SATA disk and IDE cable unplugged. When Windows was properly initialized, I performed a hot IDE cable connection, later I installed it as new hardware through Control Panel and Windows did the IDE disk installation – now it appears like a disk unit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.