Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend has a corrupted hard drive running Windows Vista. She is getting a new hard drive and has also purchased an external hard drive to back up her data. However windows downloaded an automatic updated and keeps getting held up and restarting when it trys to apply the update.

Is there a way she can disable this from the boot menu or start-up sequence?

share|improve this question

migrated from stackoverflow.com Feb 27 '10 at 3:50

This question came from our site for professional and enthusiast programmers.

2  
BTW, why is it always the girlfriend's machine ? –  mjv Feb 27 '10 at 3:49
    
you should edit you question with the new infos... –  fluxtendu Feb 28 '10 at 14:54

3 Answers 3

Updated - full answer

If it's the system drive that is corrupted and you don't already have backuped the files, you should stop using the computer until it was done, with a live cd (e.g. ubuntu, ubcd4win), by connecting the hard drive to another computer or by installing a new OS in another hard drive.

Nevertheless, to stop windows update:

  • Start in safe mode (F8 at boot, just after the bios screen; Or push repeatedly F8 from the very beginning and until the choice for the safe mode appears. If you get some other boot options (hard disk, DVD rom, etc) select (first) hard disk and continue to pushing F8)

  • Now that you have booted in safe mode, push Win+R

  • Type services.msc Enter

  • Right-click on Automatic Updates, select Properties.

  • Click the Stop button

  • Change the Startup Type to "Disabled".

If the safe mode don't work try the safe mode with command prompt where you could:

  • do a chkdsk C: /F /R /X to try to repair the hard drive and see how bad is corrupted (It's not recommended if your don't have backuped your files and your hard drive have serious damages)

  • start system restore: rstrui.exe

If even the safe mode with command prompt don't work you could:

  • boot with your vista install dvd to use the system recovery options (you could use the same chkdsk command as in safe mode with command prompt...) or to do a repair install (or a fresh one)

  • boot the restore dvd/cd from the computer manufacturer (but most of the time it can only do a fresh install, there's no repair options)

  • if no dvd was shipped at all with the computer you could use one of these, it's not possible to do a repair or fresh install with these but you could use all other system recovery options

share|improve this answer

Boot in to Safe Mode (F8 key), go into the Control Panel->Administrative Tools->Services, and disable the Automatic Updates service.

I would also run chkdisk from a recovery console (use the Vista dvd if you have one), or boot in to Safe Mode and run chkdisk from the command prompt. Set it to run on next reboot.

share|improve this answer

This is not Windows Update, I agree that Windows Update is obnoxious, but its NOT disrespectful :P Boot from Hiren's boot disc, or a Pre-Installed Environment disc and run McAfee Stinger on the system. You'll find the culprit. Stinger Link: http://vil.nai.com/vil/stinger/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.