Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What does this mean and how can I fix it?

root@bt:~# rpm -vhU
error: Failed dependencies:
    /usr/bin/python is needed by nmap-5.21-1.i386
    python >= 2.4 is needed by nmap-5.21-1.i386
root@bt:~# python -V
Python 2.5.2
root@bt:~# which python
share|improve this question
Which linux do you use? – Snark Feb 27 '10 at 7:10
backtrack 4 .... – user29606 Feb 27 '10 at 18:08
Backtrack 4 is debian based and I believe it includes nmap by default. – vtest Jul 14 '11 at 6:58

I had almost the same, just without /usr/bin/python is needed by nmap-5.21-1.i386. I had an older version of Perl.

I solved it by:

rpm -ivh --nodeps ./nmap-5.21-1.i386.rpm

nmap works correctly.

share|improve this answer
good point - you could just update the package. If -ivh doesn't work run -Uvh to update. To see if it is installed at all you can run rpm -qa | grep nmap – mjb Jul 14 '11 at 3:43

I would almost guarantee you have more than one python installed on BT. You can use whereis to confirm.

 root@bt:~# whereis python
 python: /usr/bin/python2.5 /usr/bin/python /usr/bin/python2.5-config /usr/bin/python2.4 /etc/python2.5 /etc/python /etc/python2.4 /usr/lib/python2.5 /usr/lib/python2.4 /usr/local/lib/python2.5 /usr/local/lib/python2.4 /usr/include/python2.5 /usr/include/python2.5_d /usr/include/python2.4 /usr/include/python2.4_d /usr/share/python /usr/share/man/man1/python.1.gz

It could be pointing to another version also in /usr/bin/

Best bet: to test, you could delete/move older versions of python from the directory. Or you can use this video to run an Update Everything script. That will cover your ground.

share|improve this answer
any follow up on this one? I'm still interested. – mjb Aug 1 '11 at 19:59

You must log in to answer this question.