Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a Windows 7 installation with 2 users, one administrator and the other is not. If I try to logon with the standard user it show the Welcome Screen and then logs them off immediately. If I logon with the administrator user or if I set the standard used as an administrator it works without problems.

Any idea what may be causing this?

Windows 7 Ultimate running on a netbook, AVG Antivirus, no special software or any other specific configuration.

share|improve this question

10 Answers 10

Well, this is hard to diagnose/solve since there really isn't any information and its not very widespread...

Does it happen in safe mode? And does this link by chance help in any way?

And make sure this file C:\WINDOWS\System32\Userinit.exe exists. Apparently if you have AVG free installed it might have destroyed it and messed with login.

share|improve this answer
This fixed it for me. An altered userinit string was also causing Xbox 360 disconnections. Soluto had edited the string. I uninstalled Soluto and the problem was solved.… – Iain Jul 20 '11 at 15:24

I have had the same problem. Looking for a solution, i followed the link given by Nano8Blazex.

The instructions by Microsoft Support led me to the registerkey for the location of userinit.exe. The value contained not only the location in the Windows\system32 directory, but also a location which was added by HP ProtectTools. The software was already deleted before i discovered the logon problem, but apparently this register value was left behind.

Deleting the ProtectTools location from the value, leaving only the windows\system32 location, solved my logon problem.

share|improve this answer

I had exactly the same problem:

  • Removed the standard users and made new ones; didn't work.
  • Error-checking; didn't work.
  • Kaspersky Antivirus full scan; didn't work.
  • Reinstalling Windows; didn't work.

I installed the free Ad-Aware Internet Security application by Lavasoft and ran a full scan. It found some malware - after restarting the PC the problem was completely gone.

share|improve this answer

I had this problem today and also created a new profile. I ran malware bytes in the new profile, which picked up and quarantined a trojan. I logged back into my original profile and the problem is now gone.

share|improve this answer

My first thought was check the event log.

My first hypothesis is that there is a misbehaving program that is set to run on login. This program is trying to perform some operation that mistakenly thinks it requires administrative access. Because it cannot do what it wants, it assumes that some file is locked, and initiates a logout to try to release the file lock.

Try starting the computer in safe mode, or use msconfig to run a Diagnostic Startup, so that everything else is disabled.

My other theory is that anti-virus is causing problems. i have no evidence to support that at this time: except that nearly every PC problem i've ever seen is related to anti-virus/security products in some way.

share|improve this answer

I had the same problem yesterday. I installed ESET NOD 32 Antivirus and after that, every time I opened my computer and chose my profile (administrator), it started logging off. I was then stuck on the log on screen.

What I did to fix it is start in "SAFE MODE", went to my profile, created a new profile, and deleted the old profile. It's fixed now.

share|improve this answer

Remember guys, using regedit improperly can harm your computer.

windows key+r type regedit in the box click okay go to HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Windows NT>CurrentVersion>Winlogon

look at string userinit it should look like this with the trailing , C:\WINDOWS\system32\userinit.exe, if not change it , coz if it doesn't, you have a virus infecting that file. Cheers :-)

share|improve this answer

Any modification to the registry key HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > CurrentVersion > Winlogon -> Userinit can cause this issue.

Now, the modification may be done by a malware or some OEM bloatware installed by the system manufacturer. In my case, the client had HP security tools installed, which modified the key with a protect tools entry along with C:\WINDOWS\system32\userinit.exe. Uninstalling the protect tools program will not help. You have to navigate to this registry key and delete the HP Protect tools part, leaving just the C:\WINDOWS\system32\userinit.exe part.

share|improve this answer

I had the same problem when I made an extra account for some one else. What I did was I scanned my computer for spy/mail-ware and I came up with a trojan. Then what I did was I did what Samashan suggested and I went to regedit and I found that there was all this extra crap at the end of the registry userinit.exe. right clicked to modify it, deleted all of it and made it "C:\WINDOWS\system32\userinit.exe". Then I was able to log on as the other user. Hope this helped every one!

share|improve this answer

I had a similar issue and discovered that the following two registry edits solved the problem so that I could login using a locally created account.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

Go to the above registry entry and remove any of the profiles that begin with S-1-5-21-

  • These profiles get re-created when a user logs into the machine

Or you can modify the following registry entry which allows for more cached credentials to be stored locally

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\CachedLogonsCount

default is 10 bump this up to 20 and see if you can login.

In my particular case I already had 10 cached registry entries in:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

so I bumped it up to 20 and it worked. I then deleted the other 10 cached accounts in the top registry location.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .