Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I paired the magic mouse and keyboard from my iMac with my MacBook, now I can't use the built-in trackpad and keyboard anymore. I've tried deleting them from the Bluetooth preference pane but that doesn't fix the issue.

I've used other bluetooth mice and keyboards with this MacBook before and not had this problem. My only thought is that possibly it's related to the fact that the peripherals came with the iMac and my MacBook now thinks that it's an iMac and doesn't have a built-in trackpad/keyboard.

share|improve this question

migrated from stackoverflow.com Feb 27 '10 at 13:57

This question came from our site for professional and enthusiast programmers.

2 Answers 2

You should disable the bottom option in System Preferences -> Trackpad (highlighted in red).

Trackpad Dialog

I highly doubt that your MBP would think it's an iMac. If this doesn't solve the problem, you can head into System Profiler (Applications -> Utilities -> System Profiler) and verify that the Apple internal keyboard/mouse is installed as a USB device.

System Profiler

share|improve this answer

There is an option in System Preferences that allows you to disable the internal trackpad and keyboard when you connect external ones. You need to disable this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.