Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've done this a few times already, but for some reason this time it's not working.

I have a folder called ruby (root:root - 0777) on /home/placona

I'm trying to see this folder from my WindowsXP box, but keep getting permission denied. I can see the global share though, but whenever I try clicking on the ruby share, it won't let me in.

Here's my smb.conf settings:

[global]
        log file = /var/log/samba/samba.%m
        guest account = nobody
        netbios name = DEVBOX
        server string = DEVBOX CENTOS
        workgroup = WORKGROUP
        encrypt passwords = yes
        security = share
        max log size = 50

[ruby]
        path = /home/placona/ruby

I want to be able to open this folder without using password (hence the guest account = nobody).

I tried even with password, but never seems to work.

Can anyone spot anything wrong with my settings?

share|improve this question

migrated from stackoverflow.com Feb 27 '10 at 21:18

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Samba shares need both users and settings. I'm sure you already have CentOS users, but do you also have Samba users setup?

smbpasswd -a joe

you can also add the following line to your share definitions

[ruby]
valid users = joe randi insert-samba-user-here

Oh and make sure you reload samba via

service smb restart

(Note, most code taken from: http://www.cyberciti.biz/faq/adding-a-user-to-a-samba-smb-share/ )

share|improve this answer

Try adding:

read only = no

to your [ruby] section.

share|improve this answer

Add these to your existing settings:

[global]
    map to guest = Bad User

[ruby]
    guest ok = yes
    read only = no

You've already got the guest account setting to tell Samba which account to use as the guest user; map to guest = Bad User tells Samba to automatically convert an unrecognized username to the Guest user.

You may also want to put these in your [ruby] section (tweak the permissions as needed):

directory mask = 0777
create mask = 0666
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.