Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home network - the main router connected to the internet (and has wifi) is a Netopia box. Connected to it is a Linksys router. Everything currently works - I can connect via the wireless network and get to the internet. Machines connected to the Linksys can connect with each other and connect to the internet. Both routers are configured to serve addresses via DHCP (Netopia 192.168.1.1 -> 192.168.1.99), Linksys (192.168.0.1 -> 192.168.0.100).

Here's how they are connected:

Internet <->  Netopia w/wifi (192.168.1.254) <-> Linksys (192.168.0.1)

I decided I really need to allow wireless connections to also communicate with machines behind the Linksys router. Currently the Linksys is configured to obtain an IP address via DHCP.

I thought this would be straightforward.

I configured the Linksys to have a static IP address:

  • IP: 192.168.1.100
  • Mask: 255.255.255.0
  • GW: 192.168.1.254

Then I configured a static route on the Netopia:

  • Network: 192.168.0.0
  • Mask: 255.255.255.0
  • GW: 192.168.1.100

So it should now look like this:

Internet <->  Netopia w/wifi (192.168.1.254) <-> (192.168.1.100) Linksys (192.168.0.1)

I reset both routers. I cannot ping the Netopia (192.168.1.254) from inside the Linksys network, and if I attempt to ping 192.168.0.1 from a wifi connection I get a "Destination host not available" error.

Obviously I'm missing something, but I'm not sure where.

Any ideas on what I'm missing?

share|improve this question
    
OK, I think I just realized where (and why) things are failing. I totally forgot about my Vonage box I had connected. It's actually between the two routers. That's the reason configuring the static route failed - the Vonage box is on the 10.1.0.1 network so my route would have to point to it instead of my Linksys. Doh! –  Paul Feb 27 '10 at 23:15
add comment

3 Answers

Getting a tiny bit confused reading your question, but the one thing that stands out to me is the Netopia's address.

If it has a IP of 192.168.0.0 on subnet 255.255.255.0, it will not be able to resolve a gateway of 192.168.1.100 as it is on a different network. The gateway has to be an address of 192.168.0.1-192.168.0.1.255

To be absolutely honest, it seems to be that you have over-engineered the situation, It would be a lot simpler and straight forward If you put the Netopia box on the same subnet/network and just allow all devices to acquire DHCP addresses from the Linksys box.

If you have now reset one or more and having trouble connecting, unplug everything from one machine and the troubled router then plug it in to a machine via ethernet and if it was reset, you should have no problem getting a DHCP address then applying any settings you want.

share|improve this answer
3  
+1 beat me to it. It makes way more sense to have everything on the same subnet. Give both boxes static IP addresses and have DHCP running on only ONE of the boxes. –  Kez Feb 27 '10 at 21:47
1  
The Netopia's address is 192.168.1.254 - I set-up a static route using the 192.168.0.0 address. The Linksys box is still a router so both the Netopia have to be on different subnets in order for the routing to work. If I used the Netopia's DHCP my local workstations would have a gateway address of 192.168.1.254 which they wouldn't be able to reach since the actual gateway would be the Linksys (192.168.0.1) –  Paul Feb 27 '10 at 23:04
add comment

Don't use the Linksys router as a router, just use the switch portion. Turn off DHCP on it, assign it an a static IP on the 192.168.1.x network and plug the Netopia router into one of the switch ports, not the WAN port.

Although I'm not sure I understand why you are using the Linksys router in the first place.

share|improve this answer
add comment

Unless you need them to be in different subnets for some reason. Just using mask as 255.255.0.0 in both routers and everything else the same should work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.