Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just put together a new system build in the hopes that all of my daily tasks would run smoothly and without any hiccups.

Unfortunately I am still seeing some sound and sometimes video stuttering when playing HD movies in VLC (no problems with xvid/divx files).

My setup is as follows:

Intel core i5 750 quad core 2.66mhz
4GB ram
asus p55 motherboard
radeon hd 5570 video card
650gb 7200rpm western digital sata HDD
23" Nec ea23wmi monitor
Operating System: Windows 7

What might be the main bottleneck that needs upgrading to fix my delays? Seems like the hard drive might be the problem but anything faster than 7200rpm is beyond my budget for a decent hard drive.

Could it be anything else?

share|improve this question
    
I'm keen to know the answer too, but I really doubt the HDD RPM is the cause. –  o.k.w Feb 28 '10 at 3:17

3 Answers 3

I'm assuming that you are trying to play the file off of your hard drive rather than a CD. Do you know what kind of encoding was used on the file? Have you installed any codec packs? And have you tried different players with the same result? And like o.k.w said its likely not your hard drive unless you are running something that is causing a lot of activity on it.

share|improve this answer
    
As mentioned in the question I am using VLC to play the files of my hard drive. As far as I remember VLC comes with all popular codecs built-in. Video codec of my movie is: x264, 2pass –  Absolute0 Feb 28 '10 at 13:04
    
Have you tried any alternate players? As for the codec packs some place codecs inside that can cause conflicts for certain type of files (if you are just using the one included with the VLC you should be fine.) –  Shikoru Feb 28 '10 at 21:42
    
I agree with the codec pack suggestion. Try K-lite codec pack. –  Enmos Proje Apr 27 '10 at 7:52

I had this problem and it was fixed with the following:

  1. Open the Preferences dialog and go to Input / Codecs -> Other Codecs -> FFmpeg
  2. Switch the setting for "Skip the loop filter for H.264 decoding" to All
share|improve this answer

Part of the problem is VLC itself. VLC uses a single-threaded h264 decoder, which means that even with a powerful multicore processor it can sometimes choke and can't process fast enough. The solution is to switch to a player with a better h264 decoder. I use a Mac, and had issues with HD h264-encoded video in VLC, and switched to using Plex, which is only available for Mac but is a fork of the popular XBMC player.

CoreAVC is considered one of the best and fastest h264 decoders, but isn't free (sadly). I think Boxee's (which is also a fork off XBMC) decoder is multi-threaded, and thus would perform better. You could also try MPlayer.

share|improve this answer
1  
The latest VLC 2.0 should use multiple cores... –  Andi Mar 4 '12 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.