Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Once I have done the upgrade form openSUSE11.1 to openSUSE11.2 by doing this:

zypper dup 

Now I tried to boot the system and it failed sync with VFS and kernel panic, so clearly a initrd problem . if I'm not mistaken.

Now a bit of explanation about the problem: while upgrading it shows me the error updating initramfs( I forgot the exact error or might be warning).Oh yeah it shows some grub warning too.

I have had been doing that from a chroot environment.. with all the required file mounted in proper place in the chroot environment.

Now .after bit googling and painfully looking the susegeek.com forum and opensuse.org forum

I have decided to recreate the initrd ...but the fellow called "mkinitrd" is real real crap as I hev been pointed out by few forum members.

I tried to make an initrd image by myself, failed to do so .as it shows error that device not found( if I boot into suse live cd and mount the partition ) then I tried from the chrooted env and it says "there is no space left on the device"

A bit bemused :( yeah most of you pointed it right may lack of knowledge of mine.

Kindly suggest me and show me steps to do it correctly and get opensuse11.2 up and running.

TIA

share|improve this question
    
@Sathya : Boy I have seen you have edited my post!! may I know where and why? –  unixbhaskar Mar 2 '10 at 5:08

1 Answer 1

I had a similar problem. In order to recreate your initrd with mkinitrd, you need to mount /proc and /dev into your chroot environment. I shamelessly stole this from the Gentoo handbook:

mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev

Replace /mnt/gentoo with whatever makes sense to you of course. Once I had /proc and /dev mounted, initrd worked just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.