Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I came across a very odd, it seems, bug/quirk on a client's FTP yesterday...

I don't run the FTP server, so I can't actually check anything there, but, when I log in through the command line, I'm told that it's running:

Serv-U FTP Server v6.4 for WinSock

Anyway, the client's naming convention for dated folders is "%y%m%d", so today (28th Feb 2010) would be "100228".

I noticed this problem yesterday, when I tried to create a folder called "100227" (using Cyberduck at my end)

It immediately appeared on the FTP site, but it was called "10022_". I deleted, and tried again, and the same thing happened.

For uploading, I ended up changing the naming slightly, to "2010-02-27", which was fine.

Then they sent me something, and put it in "/From_CLIENTS/10027" (they have direct access to the server, so weren't accessing it through the FTP)

When I try to access it through Cyberduck (double-clicking on the folder), it tells me:

/From_CLIENTS/10022_: No such file or directory.

I tried this in Filezilla too, and the same problem.

I then FTPd in through the terminal. Here's what I got:

ftp> cd /From_CLIENTS/100227
550 /From_CLIENTS/10022_: No such file or directory.

Which is just a bit weird.

I managed to get around it by just adding a slash at the end:

ftp> cd /From_CLIENTS/100227/
250 Directory changed to /From_CLIENTS/10022_

All very weird. And I've only come across it with that date. Every other one that I've tried works just fine.

Any thoughts? Bug in the FTP server?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It seems something is converting the numbers 100227 on the end of a line to 10022_ both when you send the command to the server, and when the server sent the success message in the final example back to you. (Unless you misquoted that final response.)

I found results from Google searches for 0227 changed to 022_ and 277 changed to 22_ that suggest a firewall product called Check Point NGX has a SmartDefense setting called FTP bounce that changes 277 to 22_ in FTP sessions.

For example, in Strange FTP behaviour through firewall, someone describes similar problems, and asks for advice if it's a firewall problem. After several suggestions about invalid characters, in the final post someone remembers running into the problem before due to a Check Point NGX firewall setting.

And here's a support document that seems to match the problem, but to view the solution you need to sign in: Check Point Support Center - FTP command line that ends with '227' is replaced with '22_'

share|improve this answer
    
Let me get in touch with the tech guy who looks after our clients' side of things and find out if this is what's going on... It sounds like it could be exactly what's causing it... –  Hugh Mar 1 '10 at 9:27

This is a windows server, sounds like its the fat32 long name issue. Prevents long file names. Try to put a file named in the same convention in the root folder. It should be named as expected.

share|improve this answer
1  
but the issue was fixed when he added "-" inbetween the values - making the name longer, not shorter! –  Phoshi Feb 28 '10 at 19:48
    
And every other dated folder in there (of the same length) was just fine... The full path to the files can be 40 or so character longer –  Hugh Feb 28 '10 at 20:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.