Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a puzzling issue regarding accessing from my home Qwest DSL connection. By default, I frequently get timeouts when accessing from Firefox, Safari, or Chrome on my Mac. I also cannot access the site from Internet Explorer in a Windows VM. However, I am able to access the site through, so I know the site is not down. Furthermore, I haven't noticed problems accessing other sites (in particular, works fine). Also, I can access when I'm connected to networks other than my home Qwest DSL connection. Together, the above make me suspect a problem with either my router (Airport Express) or, more likely, my ISP.

Anyone have any thoughts on how I can narrow down the problem further? I could call my ISP and tell them the above, but my feeling is that probably won't get me very far. I can get by browsing through a proxy, but it would be nice to figure out what's going on here and fix the problem. Oh, the only relevant discussion I found via Google was here:

Update: Thanks to those who have tried to help! I found one other thing while Googling that may be vaguely relevant:

Disabling the Accept-Encoding headers in Firefox actually didn't make a difference for me. I just thought the above might spark some other ideas about how mishandling of HTTP headers somewhere might be causing this problem. Thanks again!

Another update: In case anyone is still thinking about this; I've found that I can't surf using the links text-based browser, but I can reliably download individual files with wget. Maybe that helps?

share|improve this question
You're not alone. I have exactly the same issue. Like you, I can 'solve' it by using my university's VPN. –  MJeffryes Mar 1 '10 at 0:00
I updated my answer, and I'm having the same issues with a different provider today as well. I guess maybe @Ziggamorph is not using Qwest either? The problem is at Microsoft. –  Arjan Mar 2 '10 at 7:00
I have this problem too. I'm on TalkTalk. –  Ollie Saunders Mar 5 '10 at 20:45

2 Answers 2

What IP address does the following give you?


I get:


This is the same when using other DNS servers, like OpenDNS:

dig @

Update: as you get the same IP address, next step would be to compare the actually routing results to those of someone physically close to your place. I thought I was not having any issues using my own provider from The Netherlands, but today I cannot access that domain either. So, I guess this is a bad configuration (close) at Microsoft then; you can refer them to this post when complaining there.

traceroute -q 1

traceroute to ( [..]

 1  speedtouch (  29.850 ms
 2 (  16.181 ms
 3 (  15.721 ms
 4 (  15.172 ms
 5 (  15.599 ms
 6 (  103.566 ms
 7 (  102.136 ms
 8 (  101.973 ms
 9 (  101.625 ms
10 (  103.419 ms
11 (  124.905 ms
12 (  124.442 ms
13 (  184.476 ms
14 (  185.815 ms
15 (  184.357 ms
16 (  184.053 ms
17 (  184.450 ms
18 (  185.064 ms
19 (  187.394 ms
20 (  185.490 ms
21  *
22  *
23  *
24  *

The failing IP addresses in step 19 and 20 are Microsoft's:


OrgName:    Microsoft Corp
OrgID:      MSFT
Address:    One Microsoft Way
City:       Redmond
NetRange: -

When testing from another location then the route might be different, and then might not be using those two specific Microsoft servers (hence, taking a route through might work, when other more direct routes fail). You can test from many other locations using the list at

share|improve this answer
Thanks for taking a look! Here's what I get: [...] ;; ANSWER SECTION: 844 IN A Looks similar to what you got; at least the IP is the same. –  Manu Sridharan Mar 2 '10 at 0:30
Hi again! Unfortunately, I'm not sure that the above shows it's a problem at Microsoft. I ran traceroutes from 3 different places using and my own computer, and they all stop working after My guess is that MSFT has disallowed others from using traceroute to map their internal network. I found one other vaguely relevant thing while Googling that might spark some ideas; I'll post above. –  Manu Sridharan Mar 2 '10 at 14:03
I'm no network expert, but why would one disallow troubleshooting tools like traceroute...? –  Arjan Mar 2 '10 at 19:19
This seems to explain it: –  Manu Sridharan Mar 3 '10 at 0:06
up vote 0 down vote accepted

Never quite figured this one out, but now works for me from home. Maybe they fixed something on their end. Others may want to try again too.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.