Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble enabling administrative shares for all Administrators.

I've enabled File Sharing as well as added the LocalAccountTokenFilterPolicy registry key like all of the "solutions" out there tell you to do.

This works great for the Administrator account, but not any other Administrator.

The only way to make it work for all Administrators is to disable UAC.

Is there any way around the last step? I don't want to disable UAC unless I really have no other options.

share|improve this question
add comment

2 Answers

To resume all the steps required to use administrative shares in Windows 7:

  1. Define the network type as Home or Work
  2. Turn on File and Printer sharing
  3. In regedit, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System, and add add a new DWORD named LocalAccountTokenFilterPolicy and give it a value of 1
  4. Disable the HomeGroup (in Control Panel / Network and Internet / HomeGroup, click Leave the homegroup).

Administrative shares should work if all these steps were done.

share|improve this answer
    
This is not the case. This only works if UAC is off. I've tried both ways and it only works when UAC is off. –  Matthew Mar 3 '10 at 7:53
add comment
up vote 1 down vote accepted

Unfortunately, I was only able to get this to work by turning off UAC.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.