Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I drag an attachment out of Thunderbird onto the desktop and then double click it, it always opens in HexEdit which is almost certainly not what I want. I have to use right click -> open with on them.

If I can't make it open with the expected application can I at least change it to Preview which is likely to be right more often.


This affects all file types. XLS, PDF, JPG, ZIP, whatever.

Also, it's only Thunderbird. Downloading in Firefox or Safari or FTP or whatever produces files that open in the correct app when double clicked.


I had the computer affected stolen :( and can't reproduce the problem on my replacement. I guess I'll have to chalk this one up to a bug in Thunderbird that has probably been fixed.

share|improve this question
Are all the files of the same type? JPG, PNG, etc.? – Andrew Scagnelli Jul 23 '09 at 15:25
What version of Thunderbird are you running, and do you have any extensions installed? (If so, which ones?) – arathorn Aug 19 '09 at 17:28
Wow, stolen, what are the odds. :-( Still, please accept mpbloch's or Jonik's answer then? (Or any answer you like, of course.) – Arjan Aug 20 '09 at 20:34
up vote 1 down vote accepted

The behavior you are experiencing might be a bug. When you are dragging the attachment out of Thunderbird, it may not be setting the properties of the drag item properly for setting the file handler.

Typically, the Thunderbird UI is not as rapidly advanced as the Firefox UI. Make sure you are running the latest version of Thunderbird, then, search on to see if anyone has reported this. If not, file a bug.

share|improve this answer

You might want to take a look at this:

I use it under Leopard 10.5.7 and it works fine.

share|improve this answer
Do you use it as a workaround for the very same Thunderbird issues? I wonder if changing the default application would help here. – Arjan Aug 20 '09 at 9:56

For what it's worth, I cannot reproduce this problem using Thunderbird (20090605), i.e. the latest version, on Mac OS X 10.5.7. I tested with a couple of file types like JPG and ZIP, and it works fine.

What version are you using? If not the latest, upgrade and try again.

Also, it may be worth trying with a new Thunderbird profile, in case some config files in your current profile are corrupted. Instructions for creating a new profile. (Something going awry in the profile files has traditionally been relatively common, at least in alpha/beta versions, in other Gecko-based apps like Firefox and Mozilla.)

One more thing that comes to mind: do you have any (exotic) add-ons installed? If nothing else helped, try disabling those.

share|improve this answer

I doubt it will help you, but the "Open with" setting is stored in the resource fork. You can kind of display it using the following command from Terminal, replacing FILENAME with your file:

xattr -p FILENAME | hexdump -C

If that indeed shows some reference to your Hex editor then Thunderbird has messed up. If you don't see any reference to your Hex editor, or if it claims No such xattr:, then somehow your Mac uses that Hex editor given the file's metadata attributes. Show that metadata using:


...and compare it to the metadata of a file that opens as expected. Maybe kMDItemContentType, kMDItemContentTypeTree or kMDItemKind show something odd?

(Some shameless plug for Apple Mail, and surely not an answer to your question, so just in case you cannot fix it and are considering if you should kiss Thunderbird goodbye: Apple Mail works fine with the Energy Saver –Thunderbird always kept my Macs from sleeping, but haven't used it for 3 years– and is Time-Machine-aware. When entering Time Machine while Mail is active, you'll get the galaxy thingy for Mail rather than for Finder. You can then even find messages for accounts that don't exist anymore, and to restore them you don't need to know how Mail stores the messages on your hard disk.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .