Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Firefox 3.5.4 on Ubuntu 9.10 I have (of course) session saving (the built-in one) enabled.

I closed the main Firefox window, but the "Downloads" window was still open. And on reopen, it had forgotten about the previous tabs. This is annoying as hell, and yes, I should report (or check for) a bug. If I could stand Bugzilla, that is. :P

I have the sessionstore.js file with this older session (scanning it with less showed many of the sites I know had been open). How do I get Firefox to use this session file?

I did try to remove sessionstore.* and copy the sessionstore.js (or .bak) to the profile folder. But that doesn't have any effect.

share|improve this question
add comment

2 Answers

The simple way is to go to menu Tools > Options (it may be different in Firefox for Ubuntu).

Then, General, choose "Show my windows and tabs from last time" (instead of "Show my home page"). It works properly (found in the article Session Restore at Mozilla). If not, you could try out another way.

There's an add-on for it, Session Manager.

You could easily restore by using it.

share|improve this answer
    
Thanks for the "jumping to easy conclusions" and for the condescending tone. –  Jürgen A. Erhard Mar 1 '10 at 13:58
add comment

I would go with "Tab Mix Plus" extension. It's got a neat session management part built-in (you have to select it in the options of the extension.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.