Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two operating systems:Ubuntu 9.10 and windows xp.

When I switch from ubuntu to windows there's no sound.(Soundcard creative sound blaster audigy 24 bit). Any idea how to repare it?

share|improve this question

4 Answers 4

If you open Control Panel > Device Manager is there a question mark icons over any of the devices, either the sound or other devices?

If there is right click and get Windows to find drivers for you. As long as everything is connected (I'm assuming that you're getting sound in Ubuntu) it should "just work" (famous last words!).

I can't double check the exact sequence as I'm currently on Windows 7 here.

share|improve this answer

Is the sound service disabled? Start > Run > services.msc and look for a service called 'Windows Audio'. It should be Automatic and started.

share|improve this answer
    
I checked what you said but everything is fine. What I left out from the question is that if I start the system in windows the sound works perfectly. Only when I switch from ubuntu by reboot it seems to be disabled, but if I shut it down and wait for a sec, then start it in windows it works again. –  mistily Mar 1 '10 at 19:02

You may want to double check the BIOS settings to see if the onboard sound is enabled. Once when I installed a video card, it disabled all my onboard devices.

share|improve this answer

It seems to be a common problem in a dual boot set-up with Windows/Ubuntu 9.10, and PulseAudio (reference: http://social.answers.microsoft.com/Forums/en-US/w7music/thread/16d1bc3a-b88a-4ea1-b643-f3b9213bb490). There doesn't seem to be a resolution available, based on the linked thread, other than the suggestion to switch to a pre-9.10 version of Ubuntu.

It's possible that uninstalling PulseAudio, and switching to Alsa might work, but I've no idea for sure.

It might be worth looking at the PulseAudio's website, and their Bugs/Patches/Translations section to see if the bug's been reported or resolved as yet. They do urge that, if you're running Ubuntu (that's me and you, then...) you should read this page first.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.