Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
prevent monitor switching when closing laptop lid

About computer
I've Windows 7 on my notebook. I have connected TV via HDMI.
Notebook monitor is set as primary, and TV is set as secondary monitor.
I use extend option in 'multiple displays'.

Background
I mostly use TV to to watch movies.
Everything is ok unless I close the lid then TV switches automaticly to primary monitor, and if I was watching movie then it dissapears from the TV because it is on the secondary monitor.

Question
How to handle the lid closing problem?

share|improve this question

marked as duplicate by Kez, Diago Mar 2 '10 at 7:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Duplicate of superuser.com/questions/88548/… –  Kez Mar 1 '10 at 22:30
add comment

2 Answers

Control Panel\System and Security\Power Options\Edit Plan Settings

Change advanced power settings

Power buttons and lid

This is for Windows Vista and 7

alt text

share|improve this answer
    
I've set 'lid close action' to do nothing, and still the same... –  Tomek Tarczynski Mar 1 '10 at 22:26
    
Maybe trying to use windows + P to set the TV has the primary screen. Or it's a behavior from your laptop manufacture. Because my laptop does not do this on Windows 7. –  Michael B. Mar 1 '10 at 22:28
    
When I closed lid and opened display setting then there was only my TV, like there was no other monitor. –  Tomek Tarczynski Mar 1 '10 at 22:32
add comment

The same thing happens to me too, and I don't think there's a setting for it in the computer. It is probably something in our drivers (do you have an Nvidia card?).

My best recommendation is to close the lid, and then start the movie. If you want to open or close your laptop, just pause the movie, open or close, and then move the movie to the correct monitor.

You could also set your TV as the primary monitor, if you wanted to... Right-click the desktop and click Screen Resolution and then set the TV as your primary monitor. But seeing as you probably want your laptop to be your primary monitor, I think you'll just have to deal with the switch.

Most people at my workplace also operate with their laptop closed, because they don't like dual screens or the standalone LCD monitor is larger/clear than their laptop (and their aged eyes can't take the constant transitioning). So it appears that Windows, or the driver or whatever, is catering to the majority of people like them, who expect to sit down and use the computer on the external monitor with their laptop closed under their desk, but then when they go to a meeting, they want to just pick up their laptop, open it up, and continue what they were doing. It sounds perfect for them at least.

Edit:

Okay, it seems presentation mode does it. Though it probably leaves the screen on when you close it? (I'm not with my second monitor so I can't test it out)

Easiest way to activate presentation mode is to search (using the Windows 7 start menu search bar) for presentation and choose the first option, then check "I am currently giving a presentation" and click okay. When done, right-click the presentation icon in the system tray and click Stop presentation.

Presentation Settings

share|improve this answer
    
Yes I've NVidia card. My best solution is to set 'extend'. Choose proper resolution for regular monitor and for TV, start a movie , and then set 'projector only', and now I can close lid. –  Tomek Tarczynski Mar 1 '10 at 22:36
    
Ah yes, presentation mode. A nice fix indeed. –  Ricket Mar 1 '10 at 22:38
    
Presentation mode doesn't change anything, at least in case of my notebook. –  Tomek Tarczynski Mar 1 '10 at 22:43
    
Oh, sorry, I thought that was what you meant by projector only. –  Ricket Mar 8 '10 at 0:43
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.