Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I connect to a Samba share with authentication using Windows 7?

We have a bunch of Linux, HP-UX and AIX servers on our network with folders shared using Samba. These are not connected to our Active Directory or anything, we just type a user name and password when we connect to them. They still all work fine from Windows XP, but we've upgraded a couple of machines to Windows 7 and they can't access the shares. You get prompted for a password but it says "The specified network password is incorrect" (it's not).

share|improve this question
    
See also serverfault.com/questions/91797/… –  Mike T Jul 26 '12 at 0:11
add comment

4 Answers

up vote 18 down vote accepted
  1. Run: gpedit.msc

  2. Find:

    Console Root -> Local Computer Policy -> Computer Configuration -> Windows Settings -> -> Security Settings -> Local Policies ->Security Options

    When you're there change the following policies

  3. Microsoft network client: Send unencrypted password to third-party SMB server: Switch it to "Enabled".

  4. Network security: LAN Manager authentication level: Select the option: Send LM & NTLM - use NTLMv2 session security if negotiated.

share|improve this answer
    
Thanks, this solves the problem. It sounds like we should probably be upgrading samba on all our servers too, but that will take a while... –  Colin Pickard Mar 3 '10 at 9:56
    
doesn't work for me >:( –  endolith Jun 10 '11 at 4:22
3  
@ Cy. Instead of running gpedit.msc and doing all that navigation, secpol.msc takes you directly to your security settings. Everything else is correct otherwise.. –  user140593 Jun 16 '12 at 20:17
    
Unless you're running an old version of Samba none of this should be necessary. You're best off upgrading Samba. –  user168261 May 17 '13 at 13:11
1  
@user168261: I'm running latest version of Samba. #4 works (and is needed). #3 is unnecessary (with later Samba versions). –  Gerrat Jul 11 '13 at 21:05
show 1 more comment

I had the same problem. This did the job for me:

Get Vista and Samba to work | TechRepublic

  1. Open the Run command and type "secpol.msc".

  2. Press "continue" when prompted by Vista.

  3. Click on "Local Policies" --> "Security Options"

  4. Navigate to the policy "Network Security: LAN Manager authentication level" and open it.

  5. By default Windows Vista sets the policy to "NTVLM2 responses only". Change this to "LM and NTLM – use NTLMV2 session security if negotiated".

share|improve this answer
    
+100 if I could! Been trying to get this working for over a day. –  Gerrat Jul 11 '13 at 21:05
add comment

If you're running an old version of Samba, it's possible that you're run into this problem. Here is some further discussion. Basically, Windows Vista and 7 disable an old and insecure method of authentication which Samba was using by default. Tweaking the registry setting as described in the article should get it working. Ideally, of course, you would upgrade Samba to a new version, but that might not be possible at the moment.

If this doesn't work, could you post the version of Samba that you're running?

share|improve this answer
    
I did not have a LmCompatibilityLevel key on my Win7 machine. I don't know if creating the key would have worked? The gpedit solution worked for me anyway. –  Colin Pickard Mar 3 '10 at 10:02
1  
What version of Samba is required? Is it a samba configuration issue? –  endolith Jun 10 '11 at 4:00
add comment

I had same issue. When I try to connect I get 0x80004005 permission error:

enter image description here

While I do:

  • Change Network security: LAN Manager Authentication Level to “Send LM & NTLM responses”
  • Change Minimum Session Security for NTLM SSP to disable “Require 128-bit encryption” into “No Minimum Security”.
  • Uninistalling KB2536276.

another thing stop from done is:

  • activate Client for Microsoft Networks in my WiFi dangle Network panel.

Enabling File and printer sharing for Microsoft Networks in Network panel allow me access to Win7 shared folders.

share|improve this answer
    
add comment

protected by Community Jun 17 '12 at 6:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.