Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen some similar issues strewn throughout Google's results about this, but none seem to be corporate-specific.

I continually get the 'This connection is untrusted' screen every time I attempt to log into a secure site...for instance Gmail.

This is pretty annoying as sometimes I have to go through the process of adding the exception two or three times before it finally lets me into Gmail.

I am behind a corporate firewall, going through an internal proxy server to get to the Internet, so there is no possibility for me to update the firewall...etc.

Does anybody know a way around this? Can it simply be disabled (and is that safe)?

EDIT

I'm going to reopen this question with a bit of new information.

I have been using Google Chrome lately until today, and one thing that I noticed was that I never had this issue when using either Chrome or Internet Explorer. Is there something that these other browsers do that I need to manually do in FF?

share|improve this question

8 Answers 8

up vote 9 down vote accepted

If your system date or time is not wrong, and your problem is still not resolved, try the following. Because this problem is occurring only in your Firefox, but not IE, navigate to the secure site in IE, and determine which certificate is being used, which will be an icon somewhere around the menu bar. Then go to IE > Tools > Internet options > Content > Certificates > Trusted root certificate authorities (or maybe Intermediate certificate authorities), and find the certificate. When you find it, select Export, to export the certificate, in the default format.

Now go to Firefox > Tools > Options > Advanced > Encryption > View certifications > Authorities, and look for a certificate(s) with a similar name. If you find one, press Export, to export a backup copy of it. Now import into Firefox Authorities the certificate you exported from IE. Exit and restart Firefox. See if the "untrusted connection" problem is now fixed. If not, you could delete the imported certificate, if you wish. If problems arise, import back into Firefox Authorities the original Firefox certificate you backed up.

As soon as you finish, and everything is working OK, delete the certificates you exported, because they must be kept secure and must not be kept as files on your computer.

share|improve this answer
    
thanks!!!!!!!!!!!!!!!!!! –  espais Jul 28 '10 at 14:25
    
This worked for me too. Exported four "Certificate Authorities" which were under my company's name in IE. Used PKCS#7 format. Then in Firefox went to the Authorities page and imported all four. When importing, checked three boxes allowing all permissions for those certificate authorities. –  skypecakes Jun 5 '12 at 18:20

Chances are good that the reason it's untrusted is that the proxy is acting as a man in the middle, substituting its own ssl certificate to your browser. Firefox doesn't recognize the signing authority so it prompts you whether to trust it or not.

The question then becomes: do you trust your companies IT dept? Because they would then be able to read your mail, see your purchases, credit card info, etc. Whatever you do online that is encrypted is not encrypted to them.

share|improve this answer

Probably your company's proxy is doing a Man-in-the-middle attack to all connections (though it's not really an attack in this case). FF can't tell the difference between your company proxy and *EVIL_GUY_ON_THE_INTERNET* doing it, so it rightfully warns you.

If this is the case, your browser is misconfigured: The certificate which your company proxy uses needs to be installed into your browser; then FF will no longer complain. As a bonus, if a MITM attack occurs inside your network (between you and the proxy), you'll still get the right warning.

As to disabling the warning: I believe it's possible, but fairly complicated. Disabling is not safe because then all encrypted connections become vulnerable to MITM attacks. The solution I outlined above preserves security (as far as possible).

share|improve this answer
    
question #2 then...is it possible to find (via firefox) where this cert. is located? –  espais Mar 4 '10 at 14:35
    
@espais: No, not that I'm aware of. You'd need to ask your sysadmin (who should have configured your browser correctly in the first place). –  sleske Mar 4 '10 at 14:59
    
damn, i installed FF on my own in order to avoid using IE...thanks for the responses everybody! –  espais Mar 5 '10 at 14:26

Perhaps this is occurring because your system date or time is wrong. Enter Start > Run > cmd > date /T, to check your system date. Enter time /T, to check your system time. To set system date or time, the command is date, and time. Also, ensure your clock is in the correct local time zone; and ensure it is synchronized with internet time server time.nist.gov.

share|improve this answer

Ya know what? My computer was fine and I never had this problem until I decided to disconnect my computer one day to repaint my room. Then when I hooked everything back up, all the sites I used to visit, now Firefox has an issue with. Telling my they're all untrusted. This is making me crazy. I corrected the date and time, restarted. Now they're saying I have to mess around with all these certificates? I just want to disable what they're blocking. The only reason they're certificates in there is because of when I've visited cites and was able to at least browse by clicking to get these damn certificates. I STILL can't pay my capital one card!

share|improve this answer

I use FF3.5.5 and I get the message This connection is untrusted on https connection
every time after closing FF and deleting all cookies. FF eliminates all certificates and exception while deleting all cookies. Someone thought that was a good idea. Must have been an english geek.

share|improve this answer
1  
That isn't what Firefox does. Deleting cookies gets rid of cookies, not your cert store. I guess it might get rid of temporary exceptions as well. –  Rory Alsop Dec 13 '10 at 12:01

If you're behind a corporate firewall, are you using a proxy server? Some web proxy servers will break SSL authentication because they are trying to proxy SSL connections, which won't work by design.

Check your proxy settings. If possible, turn the proxy off, and browse direct.

share|improve this answer

I solved exporting some certificates from IE and Maxton, then importing them to Firefox and restarting. I dont know why, that's the only way I could solve this problem after the automatic Firefox update to version 33.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.