Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every now and then, when I boot up my computer, a couple keys will not work.

For example,

Pressing 'm' will result in a backslash. Or pressing 'i' might result in nothing happening.

As you can imagine it is really annoying.

I am running Windows XP Professional. I have switched keyboards, switched USB ports, but I still get the same issue.

Has anyone else run into this issue?

share|improve this question
    
Any status update regarding the suggested solutions? –  Ivo Flipse Aug 2 '09 at 10:28

9 Answers 9

up vote 17 down vote accepted
+75

With intermittent problems you need to establish a baseline.

  • Frequency of occurrence?
    • Does it happen once a day, once a week, etc?
    • Does it always start happening immediately after booting?
    • When it does occur, how frequent is the issue? So once you get your first symptom how often will you see symptoms?
  • When it happens how do you clear it up?
    • Do you need to reboot?
      • If you do need to reboot, then try something else (like logging off and on) or just using it for a while, and see if it goes away.
    • Does it clear up on its own after a while?
  • Are there any activity relationships?
    • Does it only happen after your roommate has used the computer (and maybe spilled something on the keyboard)?
    • Does it only happen on really humid days?
    • Is the temperature of the room a factor?
    • Is it more common at a certain time of the day?
    • Is there some software that you used right before it happens (maybe even before rebooting)?
  • Does it happen in all programs, or only some?
    • Every time you boot up start notepad and type a sentence or two in there (depending on the frequency of the symptoms) and see if you see it happen.
    • If it only happens in certain software, or after using some specific software then you need to look into that.
    • Next time you see it start a command line window (run CMD.exe) and see if it occurs there. It actually talks to the keyboard a little differently.
      • If you get it in a command line window then it is more likely driver or hardware.
      • If you don't get it in a command line window then it is software running at a higher level (user launched application).

If you don't know the pattern (if there is one) then it will be hard to know if you have fixed it unless you find obvious hardware or software that is causing the problem. If it does have a predictable pattern then try booking a Live Linux as was suggested - then you can test the required number of times (or usage pattern) to see if the problem reappears or not.

Hardware

It sounds like you eliminated the keyboard or the USB port, but it could also be the motherboard. If booting to Linux can reproduce the problem, then it is your motherboard or BIOS. If not then we know it is related to your software.

Malware / Virus

A malware and virus scan is a good idea. I used to do tech support and it was surprising how often someone would have some really weird behavior, and we suggested it was a virus and they would deny it, but then when they ran a scan (with updated signatures) it would return positive (and usually a pretty heavy infestation).

User Accounts

You also might try creating a new user on XP and see if that user gets the behavior too. If not then it is probably software being ran on the other user account. Slowly start installing it for the new user until you see which one causes it.

Software

Download WinPatrol (it is free) and look at what is running on start up. Then start disabling things and see if you can disrupt the pattern.

Environmental

If I were a betting man this is what I would put my money on. I remember one time I was helping a guy on tech support and I suggested something was spilled in the keyboard (most common cause) and he swore that no one would ever spill anything on the keyboard. Then after we troubleshot pretty much everything else software related he picks up the keyboard and water pours out on him. Turns out the keyboard was sitting on the floor near the kitchen, and the kids had spilled water in the kitchen, which flowed out and into the carpet, which got in the keyboard.

It gets better. After he poured the water out he discovered the keyboard was infested with ants. At this point he was getting really grumpy with his wife and kids about the no food or drink near the computer rule. I told him that tech support didn't support ants in the keyboard. He was going to try running it through the dishwasher.

Ants!

You could try some bug spray as a preventative measure, but your mileage may vary. Even though you replaced the keyboard, the ants may have come back due to crumbs near by.

share|improve this answer
1  
Insightful, concisely written and the ant hive story you shared was ridiculously funny to boot. Thanks for sharing your experience with us. –  facepalmd Jul 30 '09 at 11:54
1  
This exact thing happened to me, but in my case it was a roach. Need to stop eating in front of the computer dang it. It was on my C64, which tells you how old THAT story is. –  JohnFx Aug 1 '09 at 2:18
1  
Seems the bugs got beyond the software borders, we need a wall of fire! (Holds water away too...) –  Tom Wijsman Sep 11 '09 at 7:30
    
I was using a laptop, and I could fix it hitting NUM LK/SCRN LK keys :) –  nawfal Sep 15 at 15:14

Are you possibly using the wrong keyboard language in your windows settings?

  1. Click Start and then Control Panel
  2. In Control Panel, if you are in Category View, click on Switch to Classic View (top left corner)
  3. Open Regional and Language Options.
  4. Click on the Languages tab.
  5. Under Text services and input languages, click on the Details button.
  6. Under Installed services, click Add.
  7. In the Add Input Language dialog box, choose the input language and keyboard layout or Input Method Editor (IME) you want to add.
  8. Click OK twice. You should now see a language indicator in the System Tray (located at bottom right hand corner of the desktop by default). You can switch between different input languages (= keyboard languages) by pressing the Alt + Shift keys

If a language does not appear in the Input language list, the fonts for that language might not be installed. If that is the case, follow the instructions below.

You can also try looking here http://msdn.microsoft.com/en-us/goglobal/bb688179.aspx

share|improve this answer
1  
wood a invalid setting like this cause random keys to not work. Its different keys each time I reboot, not pattern. –  joe Jul 23 '09 at 16:36
    
Joe: If it's different each time you reboot, it may not be a problem with the language settings. The only thing I can possibly think of is that your keyboard may have some type of short in it, or there is some type of interference going on which may be screwing up the signals that the keys generate. After that, all I can think of would be somebody playing a joke on you somehow. –  TheTXI Jul 23 '09 at 17:43
1  
After re-reading the question, I don't think it would be a short with the keyboard since you have said that you have already been switching out keyboards. –  TheTXI Jul 23 '09 at 17:43

If you have multiple languages/keyboards setup, you can switch between them using Alt-Shift. It is pretty easy to hit that combo during the course of the day as a typo and completely confuse yourself when your keyboard stops behaving as expected.

If you have the language toolbar displayed you can verify that the language is changing when typing Alt-Shift.

share|improve this answer
    
Thanks, but I verified that it is not the language switching. –  joe Jul 27 '09 at 20:43

There So many reasons for this issue : Try all of these

Solution 1

You need to ensue your regional settings are correct, as it sounds like your keyboard mapping is messed up.

OPen the control panel > Date, Time, Language, and Regional Options > Regional and Language options. Then make sure ALL the drop downs are correct for your country 1/Standards and Format - Regional options tab 2/location - Regional options tab 3/Languages tab > Details Button > settings tab > Default input language 4/Advanced tab top drop down.

Solution 2

Virus and malware scans are only as good as the updates.

Solution 3

Your keyboard language may not be correct. You have to select keyboard in the control panel.

share|improve this answer

You may want to investigate if someone/something has loaded unwanted/malicious software on your system.

The link below seems like it could describe your symptoms. Have you run up to date spyware/antivirus scans?

http://www.rjlsoftware.com/software/entertainment/replacekeys/

share|improve this answer

Hit the Scroll Lock key. That should fix the keys for you. If not, try hitting the Scroll Lock key while holding down one or more of the keyboard's modifier keys (fn, ctl, alt).


EDIT1: Ok, I thought this was a far more common a complaint than it actually is. The only link that I've found so far that seems to bear me out is in the comments of this article here.

Of course I've assumed that if you had a PS/2 port you'd be using it instead by now. (adapters should be available for usb connectors)


EDIT2: Another thing you can try if you have your installation CD is you could try to reinstall USB and keyboard drivers OR you can try and update your drivers OR you can rollback your drivers individually OR just rollback from System Restore to a point everything was working fine. :-)

btw, the link above says that the user's right side of the keyboard would produce incorrect outputs, and your 'm' and 'i' keys are both right side keys of a keyboard.

share|improve this answer

I would suggest further diagnostics: try booting the computer from a USB distribution of GNU/Linux such as Slax or Puppy Linux. Does the keyboard work with that?

Also, try the on-screen keyboard built into Windows and, if those OSes don't work with hardware keyboards, the Gnu/Linux distro you choose. If the onscreen keyboards work but the other OSes don't, it's a hardware problem. If the other OSes work and the onscreen keyboard doesn't, you have a strange software problem and I can only suggest reinstalling windows.

PS. I know about language settings (and personally use dvorak) and this isn't it; that wouldn't cause random problems at startup, as the keyboard is always the same at startup.

share|improve this answer

It doesn't sound like this is the case here, but you might see if someone has hit you with the Phantom Keystroker V2 from ThinkGeek:

Phantom Keystroker V2 from ThinkGeek

From their website:

Product Features

  • Attach this evil prank device to your victim's computer and it makes random mouse movements and types out odd garbage text and phrases
  • Switches on side choose between keyboard garbage typing, caps lock-toggle, annoying mouse movements or all three
  • Adjustment dial sets the duration between annoying "events"
  • Works on any OS (Caps-Lock toggle does not work on the Mac. May not work on some Linux systems depending on configuration.)
  • Victim's computer requires USB port

So if they just set it to keyboard, that might be what is happening.

share|improve this answer

Could you try in your bios if the keys are messed up there as well?

It sounds like it's being recognized as a different type (random) of keyboard. Since you claim it's keyboard independent it has to be a "software" problem.

If it works correct in bios, then it must be your Windows settings.

You can try to change the language settings and force it to use the proper one OR you have to try and reinstall your keyboard drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.