Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Logitech MX3200 wireless keyboard and mouse set, and keyboard stopped working. I was working with it and it just stopped in the middle of using it.

Some notes:

  • The mouse still works flawlessly,
  • i've tried to reconnect the KB
  • i've tried to reconnect everything, mouse reconnects, keyboard reconnects (or pretends to)
  • I've tried to hard reset (holding the connect button on the receiver for 10 seconds).
  • I've tried new batteries
  • I took out the batteries out of the KB & Mouse and unplugged the receiver over night.
  • The media keys still work (launches winamp) but they main keys does not

At this point, i've tried everything I've seen online. I just want to know is my keyboard dead in the water?

I would say it's been about 8 months to a year since i've bought it, and the articles i find on the internet all say that's as long as they last... is this true? what's everyone's experience? I hope it's not true.

share|improve this question

migrated from serverfault.com Mar 2 '10 at 20:58

This question came from our site for professional system and network administrators.

2 Answers 2

up vote 3 down vote accepted

I had this happen, you need to have a windows installation and install the logitech software 'setpoint'. You can then reinitialize the encryption using some wizard ... I remember with this the media keys still worked as you say, so I think this is the ticket :)

share|improve this answer
    
is it encrypted out of the box? I never installed any of the logitech drivers and it's been working great (on linux and windows thru a KVM switch). Would it be the encryption thing if i never set it up in the first place? I'll try it when i get home. –  Roy Rico May 27 '09 at 1:05
    
So what happened with this? I'm in pretty much the same boat. I didn't install any logitech drivers and everything just worked up until last night. I also use a KVM switch between a linux & windows XP box. The mouse works fine on both but the keyboard quit on both, even with new batteries. And the SetPoint software works only on windows. What did you end up doing to fix this? –  kajaco Jul 3 '10 at 20:14
    
Well with the setpoint software if fixed it in the keyboard itself I guess so it it worked. I was then able to boot into Linux. I would remove your KVM and and see if you get get it working directly with Windows. Once that happens, still by pass the kvm and see if it works with Linux. Then try putting the KVM back into play. –  Kyle Brandt Jul 3 '10 at 21:20

It worked for me you need to download Setpoint from Logitech drivers and configure encryption on Windows, you can then delete Windows ;)

I used a virtualbox image with Windows xp on a Linux host and then deleted that image.

I'm using it on linux now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.