Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using an Intel-based macbook, I made a new partition with BootCamp, after that I inserted debian installation CD, deleted the FAT32 partition that was made by BootCamp, made 3 new partitions: / ex3 /home ex3 and a swap partition,

after installing debian, I restarted macbook, but it couldn't recognize linux partitions, in Mac OSx I can't find any of these partitions as startup disks, and I can't mount them in Disk Utility, How can I access these partitions? how can I boot to debian?

share|improve this question
up vote 1 down vote accepted

I don't know how to access your linux partitions from Disk Utility, but for booting i would definitely recommend rEFIt. It shows a boot menu at startup, and (if everything is set up right) lets you boot into Debian.

share|improve this answer
well, I tried rEFIt, and it only shows me the macOSx and rEFIt menu& tools, albeit, the linux partitions are listed in MBR partition list... but I still can't boot into debian...:( – mali Mar 3 '10 at 18:22
Have you tried syncing the partition tables in rEFIt? – trolle3000 Mar 3 '10 at 19:20
yup. after syncing it still doesn't recognize the partition, by the way, my linux partition is on the same HD as my macOSX, is that the problem? – mali Mar 3 '10 at 19:47
No, I've had Ubuntu and OSX on the same HD working fine. Are you sure you installed GRUB in the right place? – trolle3000 Mar 3 '10 at 23:09
hmm.. I'm not sure, how can check it now? – mali Mar 4 '10 at 7:26

Mac OS X doesn't recognize ext2/ext3 partitions.

You can use a MacFUSE plugin like fuse-ext2 to mount them in the Finder and make them available to the whole system.

If you only want to boot on one of these partitions, hold alt while booting your computer to select the boot disk (you don't need FUSE plugins to do this).

share|improve this answer
I tried the alt key, but it only shows me the Macintosh HD. – mali Mar 3 '10 at 9:33
That's why you might want to look into rEFIt – trolle3000 Mar 3 '10 at 15:00

you could try holding the 'option' button when your computer boots. This will allow you to select the drive to boot from.

for more info, or some other interesting boot related keys, look here

hope this helps

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .