Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Thinkpad R51 and Windows 7 just doesn't give me a Sleep option.

I suspect it's because it's running the default VGA driver. The machine has an Intel 855 GME graphics adapter but there doesn't seem to be a WDDM driver available publicly. Lenovo's driver download page just says that drivers for Vista are bundled with the OS. Apparently, they aren't bundled with Windows 7 as it always defaults to a generic VGA driver.

Is there a reliable way to get Sleep to work on this machine?

share|improve this question

3 Answers 3

Intel has a driver available on their website for this chipset: Intel 852/855 Chipset Family. Click on the "Download" link next to Intel 855 GME and then try the driver for WIndows XP Professional. I had a similar problem with my display driver for my Dell Inspiron 1501 (which isn't that old - it came with Windows Vista!). I ended up using the chipset driver, rather than Dell's branded driver (same functionality).

You can also try the Intel Driver Update Utility if you're not sure which chipset/graphics controller you have (although it looks like you do).

share|improve this answer

Go to Power Options and then click the profile you are using - change setting. After that go to "USB Settings" and turn Selective suspend to Disabled.

AFter you change the setting then go look at the start button. You will have the sleep fuction back. :)

share|improve this answer
up vote 0 down vote accepted

This was indeed due to the lack of appropriate drivers for the graphics chipset. Intel doesn't provide WDDM drivers for the 855 series. The only way out is to use the drivers that come with Windows Vista.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.