Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a D-Link DSL-G604T wired to two different XP machines working fine for about an year. I recently had to unplug all them off to replace the carpet. When I plugged them back in one of the PCs was working and on the other I was seeing "Limited or no connectivity" error.

I power-cycled the router a few times, but then I found that both PCs now display "Limited or no connectivity" error. The router has a blinking status light and a solid ADSL green light. According to the manual, a blinking status light indicated no problems.

I've reset the router a few times and reset it to factory defaults and still getting the same issue. I didn't think there are any problems with the PCs. No changes were made to them between unplugging and plugging them back in.

I had a Linksys cable router, so plugged the PCs into this. They found the router and connected and renewed IPs immediately. But as soon as I plugged them back into the D-Link I get the same error.

Do you have any suggestions why I'm getting this behaviour on the D-Link?


share|improve this question

Has the DHCP Settings on the router gone screwy?
What IP Addresses are the machines getting?
Try setting them statically to two IP addresses that correspond with the router.

share|improve this answer
PCs are getting no IP address ( I will check the DHCP settings on the router tonight. Although I imagined that when I reset the router to factory settings it would have reset the DHCP settings to default as well. – Sivakanesh Mar 3 '10 at 10:11
Tried to access the router via the web interface, but it seems that the PCs are unable to connect to that as well. I concluded that there was something wrong with the router and got a new Netgear one, and it is working fine now. While researching on this issue I found a great many people out there having similar issues with D-Link. – Sivakanesh Mar 4 '10 at 12:21

No changes were made to them between unplugging and plugging them back in.

Unplugging and plugging them back in can be considered as changes. Which involve network cables, right? I'd try with another network cable.

share|improve this answer
I've used the same cables. I know because they are colour tagged. But I have also tried another cable. – Sivakanesh Mar 3 '10 at 10:08

Check power adapter. Possible there is dry capacitor. I has issue with Asus WL-500gP v2.

share|improve this answer
I know little about power supplies/adapter, but if the router lights up as it was supposed to, i.e. all the lights come on, then I would assume the power supply is OK. However, if you were right about this I will need to find another power adapter anyway. But As I said I got a Netgear replacement and it is working fine. – Sivakanesh Mar 4 '10 at 21:19
up vote 0 down vote accepted

Thanks for all your responses guys. I after spending more unproductive hours I couldn't event get the PC to see the router via the web interface. I really do think it was a hardware fault.

I just got a new Netgear modem/router and things are working fine using all the old cables.

share|improve this answer
Perhaps the carpet changing caused some static discharge into the router...? – Shevek Mar 5 '10 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .