Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

My laptop was working fine, but I ran a comprehensive disk check (Stage 1--5) just for the heck of it. The check stops at stage 4 and gives no feedback. I let it sit there for 1.5 hours but it didn't give any more indications on the screen or move to stage 5.

The problem is: The chkdsk hangup prevents me from being able to log in. I can't get past it to use my machine. I haven't found a way to turn it off.

I opened the Windows command prompt using my system recovery disk and typed "chkntfs /x c:" but it did not stop the chkdsk from running again on restart.

Addendum: Now that I can login, I ran HD Tune Pro 4.01 and found that 1.5% of my blocks are damaged. It's time to buy a new HDD.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, CharlieRB, DragonLord, Brad Patton, HackToHell Apr 20 '13 at 16:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

up vote 2 down vote accepted

I would try booting into safemode and doing this:

http://support.microsoft.com/kb/831426/ja

It's a solution for XP, but the registry key it talks about is the same for Windows 7.

share|improve this answer
    
Starting in Safe Mode (using the HDD and not the CD) allowed me to startup in "last known good configuration (advanced)" I turned of the disk check using the article. Restarted and looks good. –  snitzr Mar 3 '10 at 16:33

If you need detailed info just How to disable CHKDSK at Startup:

  1. Go to to Run, type regedit and hit Enter
  2. In the Registry Editor go to the location HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
  3. Here you can see a DWORD BootExecute , Right click and select Edit and change the DWORD value to autocheck autochk *
share|improve this answer
3  
Welcome to Super User, Paventhan! I noticed you were posting just a link to your blog. However, we require answers to consist of more than just a link. So please, mention the relevant details in your answer. Also, if the sole purpose of your account is to promote your blog, then please be cautious – this is akin to spamming and could result in your answers being removed entirely. –  slhck Oct 6 '12 at 7:26

I had a similar problem with Windows 7 chkdsk hanging at Stage 4. Then chkdsk started at every boot up. C: was marked as dirty after that. I cleared the problem by setting chkdsk /f to run during next boot up. Next boot up chkdsk ran through stage 3 successfully. That cleared the problem of chkdsk running at boot up every time. My hard drive is probably bad which prevented chkdsk /r from completing but allowed me to get back into the computer to retrieve files.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.