Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have multiple computers that all seem to have View Source disabled from the content menu when you right click on a web page. Now I know it's not that the web page is some how disabling it, I'm pretty sure thats not even possible. But alas I have at least 3 machines in my office (not on AD) that have this problem. I have also worked on clients computers that have this same issue. It's down right maddening!

I tried to Google for it, but it just shows results from the dawn of IE6 in all of it's "glory" with a bug where if the cache was full it would be disabled. But this is not the case in IE8.

Any body have a clue why this is happening, or a fix for it? Maybe a reg setting?

Update:
So I got a little closer to solving it, but there was still an issue on one computer where it allowed it not is HTTP, but not in HTTPS. One other computer works correctly in both. I Found these two keys missing in the registry:

[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\View Source Editor]
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor]
share|improve this question
    
You could probably use Tools->Developer Tools and choose script tab to get the complete source code in IE8. –  vpram86 Mar 5 '10 at 14:31
    
Thats more of a quick and dirty workaround, and not so much a fix. I'm looking for an actual fix here for both HTTP and HTTPS. Plus while I did not mention it I have the same issue in IE7 clients. Though I am pushing people into IE8 as much as possible. So the dev toolbar is not a default option in IE7. –  Tim Meers Mar 5 '10 at 15:14
    
Is it worth the trouble?? Why not FF and Firebug ? –  Krazy_Kaos Mar 9 '10 at 9:02
    
App is locked in on IE, so I'm not able to do it with FF. Plus if it were a clients computer, I'm sure they would not want me installing additional apps. Though I do love me some Firebug thats for sure. Oh and yes, it's worth the trouble. Even beyond being locked into IE on this LOB app –  Tim Meers Mar 9 '10 at 16:12
1  
Just today I ran into that problem on a single user PC (Windows XP, IE8, part of an AD) and seeking a solution. Developer Tools -> View -> Source -> Original works. I don't have the above mentioned registry entries. I'd like to solve this so view source works as expected again. I also disabled a lot of add-ons, but didn't change anything. –  mark Jun 21 '10 at 14:52

3 Answers 3

is it happening for https sites? if so try tools - Internet Options - Advance go to security tab and check-off Do not save encrypted pages to disk.

Try Bing search insted of google, it gives more proper search result (atleast for this.)

share|improve this answer
  1. Press F12 to bring up the Developer Tools window
  2. Go to File -> Customize Internet Explorer View Source and select the viewer you want

This should fix the context menu and restore the registry entries. Worked for me!

share|improve this answer

I had the same problem on Oracle i-store (on IE8) and following solution can be used as a workaround on secure (https) pages:

once the secure page is displayed, go to: Tools-->Developer tools --> View tab --> Source --> original

share|improve this answer
    
That's a nice workaround for the moment, still seeking the solution to fix this. –  mark Jun 21 '10 at 14:53
    
@mark Does my answer help? I tried everything else I found here and online, but that was the only thing that fixed it. –  Matthew Read Aug 11 '11 at 2:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.