Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Eclipse and Firefox on Windows 7.

Ctrl + Shift + g in Eclipse is supposed to do a search for references, but instead it does a Google search in Firefox.

Why is this happening, and how can I make it stop?

share|improve this question
    
Also affects other browsers (I had it with Chrome) when the cause is due to the accepted answer below. This is not a browser-specific problem (although that's not obvious until you know the solution). –  bacar Nov 15 '13 at 13:33
add comment

2 Answers

Open your workspace preferences in Eclipse (Window -> Preferences), and go to the "General -> Keys" category.

There, try to search for "ctrl+shift+g", to see if this is bound to a command. You can search also for "References in workspace", to find the command you actually want to execute, and associate ctrl+shift+g back to this one (assuming the problem is only related to Eclipse configuration).

share|improve this answer
    
Thanx for the hint. I verified that the command 'References in workspace' is bound to Ctrl+Shift+G. So I guess the problem is NOT related to eclipse, but to Windows or Firefox configuration? –  Jens Schauder Mar 4 '10 at 10:22
1  
@Jens - very probably, in this case. I don't think Firefox has something to do with it, though. I guess that if you change your default browser to another one, it will probably open in this one. You could try that to rule Firefox out of the problem (and if so, edit your question with these details). –  Gnoupi Mar 4 '10 at 11:01
1  
@Jens - Also, to rule out Eclipse, try simply this ctrl+shift+g without Eclipse launched? –  Gnoupi Mar 4 '10 at 11:03
1  
I found the culprint. It was a ClipX an otherwise really nice tool. Thanx. –  Jens Schauder Mar 4 '10 at 13:31
    
@Jens - Since this is the solution to your problem, consider writing it as another answer, and accepting it as the correct one (though you will be able to accept it only in next days). This way, it will close nicely this question, with its solution. –  Gnoupi Mar 4 '10 at 13:41
add comment
up vote 11 down vote accepted

ClipX a clip board history tool was using the shortcut. I removed the shortcut setting there, and now everything works fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.