Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi I have a problem with my excel .. I want to paste one bunch of rows to another excel document and I can't do it with simple copy/paste ..

I can copy then paste to notepad then copy again and paste to other file

I have loads of thing to copy .. is there a way arround this ?

share|improve this question

migrated from stackoverflow.com Mar 4 '10 at 16:07

This question came from our site for professional and enthusiast programmers.

    
Does not sound programming related, but what happens when you try to copy/paste directly from one document to another? –  Peter Lang Mar 4 '10 at 15:48
    
@Peter Lang nothing can't choose paste and can't CTRL + v –  user24795 Mar 4 '10 at 15:48
    
So you open both documents, select some cells in the first document, press Ctrl+c, change to the other document and press Ctrl+v, and nothing happens? What happens when you try to paste it somewhere in your first document? –  Peter Lang Mar 4 '10 at 15:51
    
@Peter Lang So you open both documents, select some cells in the first document, press Ctrl+c, change to the other document and press Ctrl+v, and nothing happens? - YES , it pastes just fine when I paste it in first document on into external notepad file. –  user24795 Mar 4 '10 at 15:55

5 Answers 5

Excel has a peculiar way of handling the clipboard. The clipboard is the temporary place where the copied data goes.

Be sure not to do anything that could clear the clipboard between copying and pasting. It includes:

  • pushing Esc
  • pushing Enter
  • editing any cell
  • clicking the formula bar
  • saving a workbook
  • running some macros

... and many I'm probably not even aware of. A good indicator of whether or not your data is in the clipboard is the status bar. If it shows "Select destination and press ENTER or choose Paste", then you're good.

share|improve this answer

Excel will usually try to preserve formulas, references, etc.

If you just want to copy over the values, you can copy, then from the Edit menu, select Paste Special - you can then select what and how you want to paste the clipboard into the new sheet.

I haven't found a keyboard shortcut for this, unfortunately, nor a way to default the paste to "values only".

share|improve this answer

The Excel files are probably opened in separate instances of Excel. Doing this means losing some of Excel's functionality.

Try opening one file, then open the other by pressing Ctrl + O and navigating to the file.

The copy paste should work then.

share|improve this answer

Have you changed DDE settings for Excel?

Excel Button -> Excel Options -> Advanced -> Ignore other application that use DDE.

This is often checked to enable multiple instances of Excel, but I have found that doing this can effect how those instances interact with each other (including copy/paste).

share|improve this answer

Well, this should work fine:

  1. Open both documents
  2. Select the cells you want to copy in the first document
  3. Press Ctrl+c to copy the cells
  4. Notice the dashed border around your selected cells
  5. Go to the other document
  6. Press Ctrl+v to paste the copied cells
share|improve this answer
    
@Peter Lang tried that m8 not working .. –  user24795 Mar 4 '10 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.