Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What is the correct way to do it? This are the steps I have taken:

  1. Disable DHCP in Wireless router
  2. Setup a fixed IP (192.168.1.2) and telling that the default Gateway is 192.168.1.1 (the ADSL router)
  3. Plugged the Ethernet cable from the ADSL router to the "Internet" port in the wireless router.

It does not work.

share|improve this question
    
Is the ADSL device a modem or a router? Your question text and the title seem to conflict. –  squircle Mar 4 '10 at 21:24
    
In addition to what the purple pixel said above, name the model of the "model" (which I'm guessing could be "modem"/router) –  ldigas Mar 4 '10 at 21:31
    
Yes, thanks for pointing the error. Now fixed. –  Eduardo Molteni Mar 4 '10 at 21:49
    
I'm trying to avoid bringing specifics models of routers to learn about the process, but I guess it is different in every case. Weird –  Eduardo Molteni Mar 4 '10 at 21:51
    
Actuaally, it's rather similar in most cases. But while learning, it is better to view one specific example (model), than to go "the general route". –  ldigas Mar 4 '10 at 22:32

7 Answers 7

Got a little complicated whilst writing this - 1 refers to your modem, 2 refers to your wireless router.

This is one thing I hate doing as it can change based on device manufacturer and features. Personally, if you can upgrade 1 and 2 and just have one device, you will be better off.

For a start, if your 2 actually supports this e.g. has an Ethernet WAN port instead of a smaller telephone line adapter, you may not even have to disable DHCP anywhere - simply make sure the 1 works (connect it up to one pc) and if it does, plug it in to to the 2, and then it should "just work" - if it doesn't, your 1 is more likely to be an actual router (just with one port).

so, if 1 is actually a router instead of a modem, I would recommend that you see if you can change the mode of 2 and basically disable all routing and change it to an access point, this will then do all the DHCP and everything else at 1 whilst just providing an access point to wired and wireless devices - by far the best way. (After changing this, you may have to first manually set the ip of 2, this will mean that all devices are pingable and accessible on your network and the easiest to manage.

share|improve this answer
    
I've guessed that it would just work, but spend 3+ hours yesterday trying to make it work. The thing that makes no sense is that some say to plug the cable to the standard (numbered) port of 2. I will try to make it an access point tonight –  Eduardo Molteni Mar 4 '10 at 21:47
    
it makes no sense... but it works. Its something to do with vlans i suspect- that connector is a network segment on its own –  Journeyman Geek Mar 5 '10 at 1:09
    
@The Journeyman geek, it is not vlans - it is simply subnets, routing tables, NAT etc... it is just the way the devices are designed to "route" information... Routers are designed for two (or more, model depending) networks - typically commercial ones have a built in modem and switch, but if you go back (quite a few now) years, when you didn't get so many "all in one" type devices, you really start to learn what features each device brings - and how they work from a deeper level (Hope this comment makes sense... very tired writing it!) –  William Hilsum Mar 5 '10 at 1:38

It depends how your provider initially set this up and how you want to set it up.

The setup you allude to is where the ADSL modem is connecting to your provider as well as routing and taking care of DHCP, etc.

A preferred setup is where the ADSL modem simply handles connecting to your provider. Often this means the router has to be configured to do PPPoE, authenticating to the provider via the modem. The router can then handle DHCP, NAT, filtering, port forwarding, etc. Sometimes this setup requires setting the modem to some sort of pass through mode.

Post your exact device information for better help.

share|improve this answer

Your instructions are correct, but you'll also want to disable NAT on the modem.

You may be having an IP conflict. Did you release your DHCP IPs from your client machines before installing your wireless router? Maybe you assigned your wireless router a 192.168.x.x IP that was in use by another device.

share|improve this answer
    
The instructions are wrong, step 3 should be to connect the 2 routers lan port to lan port, not lan port to internet port. –  user23307 Mar 5 '10 at 3:04

Without knowing what devices you use: if one of them (preferably the wireless router) supports "bridging mode" then that device can be thought of as being some kind of "slave". The other device will then take care of assigning IP addresses and the routing; the "slave" will just take care of passing everything to that device. This will solve a lot of problems in one go (like "double-NAT" issues).

Unfortunately, the term "bridging" is used in many different meanings, like an Apple AirPort Express can act as a bridge in three different ways:

  • If you have an existing wired network, it can bridge this network to wireless clients. (This is what you want.)
  • If it is set up as a WDS remote or relay station, it can bridge the wireless network to wired clients.
  • If it is set up as a WDS remote or relay station, it can bridge the wireless network to wireless clients (or "wirelessly extend" the range of the network).

So: we need more details to tell you the name used in your situation (or maybe point you to duplicate questions here at Super User).

share|improve this answer

step by step - you seem to have done some of this already, but this certainly works

  1. go to the wireless router setup and turn off its dhcp server and set up a fixed ip address to it.
  2. connect the wired router and the wireless router - lan connection to lan connection (as odd as it sounds)
  3. check if you can access the wireless router from a box connected to the wired router 4) if so test the wired connection, then the wireless.

This worked in a similar setup for me and others

share|improve this answer
up vote 0 down vote accepted

Tried again from zero and works right away (The magic of PCs :)

Things I did:

  1. Leave the IP of the Wireless router in automatic
  2. Change the internal IP to 192.168.5.1 (I think here was my mistake last time)
  3. Leave DHCP ON and starting with IPs 192.168.5.100
  4. Presto! All works like a charm in 5 minutes.

Thanks all for answers!

share|improve this answer
    
no, this is wrong. you had the step 3 in your original instructions backwards. superuser.com/questions/116255/… has it right, you need to connect them lan-to-lan. This is why you disable the 2nd dhcp server first. –  user23307 Mar 5 '10 at 3:03
    
:confused: Maybe you are right, but this setup just worked (and I will no touch it) –  Eduardo Molteni Mar 5 '10 at 13:34

here is a good article, 4 ways to do that. It is very easy:

http://www.umrezen.in.rs/networking/4-ways-to-set-up-wirless-broadband-router-and-adsl-router/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.