Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have attached an external USB disk to my debian gnu/linux system. The disk showed up as device /dev/sdc, and I prepared it like this:

  • created a single partition with fdisk /dev/sdc (and some more commands in the interactive session that follows)
  • formatted the partition with mkfs.msdos /dev/sdc1

If I then attach the USB disk to a Windows XP or Vista system, then no new drive becomes available. The disk and its partition show up fine in the disk managment tool under "computer management", but apparently the file system in the partition is not recognized.

How do I create a FAT32 file system which can actually be used in windows?

edit: I've given up on this and went with a NTFS file system created by windows. In debian lenny this can be mounted read-write but apparently it requires you to install the "ntfs-3g" package and explicitly pass the -t ntfs-3g option to the mount command.

share|improve this question
    
Since you want a FAT32 file system, why not create it in Windows to begin with, then mount it in Linux? –  Joe Internet Mar 5 '10 at 2:19
    
Because windows only gives me the option to create a NTFS file system –  wcoenen Mar 5 '10 at 9:22
    
Linux will mount an NTFS file system too –  gorilla Mar 5 '10 at 11:14
    
@gorilla: as shown by the edit I made an hour before your comment, I was already aware of that. I just would have preferred FAT32 because it has better portability without the need to install additional utilities and drivers. –  wcoenen Mar 5 '10 at 15:06
add comment

3 Answers

If you want a GUI, I would recommend using Gparted (link to Live cd - however, it is in most repositories) - it works very well.

With Gparted, you can create, delete, move and change partitions and file systems - very easily.

You can create/format to NTFS or Fat32 using this which should both be Windows and Linux compatible.

share|improve this answer
add comment

You should probably delete MBR before repartitioning. In other words:

dd if=/dev/zero of=/dev/sdc bs=512 count=1
share|improve this answer
add comment

I believe mkfs.msdos creates a FAT filesystem (the one with 8.3 file naming conventions).

Its mkfs.vfat that creates a FAT32 filesystem which is accessible from Windows too (since I've tried this). And it supports long filenames.

share|improve this answer
    
I tried both. Neither resulted in file system recognized by XP or Vista. Though the problem may have been with the way I created the partition, rather than the file system in it. –  wcoenen Mar 14 '10 at 22:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.