Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer has a weird thing going on. When windows starts up I see the System process using 100% of the CPU for about 2-3 minutes and then it subsides. I wonder why this happens. I'm sure my computer is virus and spyware free. And I don't face no other problems once this 2-3 minutes pass by. Any idea why this happens?

share|improve this question
    
What version of Windows are you using? –  M4dRefluX Jul 24 '09 at 17:04

7 Answers 7

This may be caused by a "zombie" print job (that is, one which could not be successfully printed for some reason, but which was not automatically deleted by the print spooler). When this happens, the system will continue trying to print the document over and over, spiking your System process. Check to see if a document is stuck in your print queue, and if so, delete it.

share|improve this answer

Try sysinternals process explorer, maybe you get more information, what exactly
happening after start.

share|improve this answer

check what you have in your user profile's start menu->all programs->startup menu item. perhaps you are starting a host (or maybe just one) of items that take time on start up.

share|improve this answer

If you don't find the culprit in Start, All Programs, Startup Items then you may want to check for other startup items by using msconfig.

Click on Start, Run (may be different in vista) type in msconfig, press ok, and click on the startup tab at the top.

These are all of the programs that start with your machine. It is safe to disable all of these items but you shouldn't have to. If you notice the name of a program you don't use anymore uncheck it here. If something seems fishy google it to find out what it does and uncheck it if you want. When you're finished cleaning these out press ok and restart.

share|improve this answer
    
+1 by trial and error you can often disable a lot of useless programs that run at startup –  Matthew Lock Sep 2 '09 at 7:34

If it's your system process that's using that much cpu it can be the cause of a bad driver or your antivirus software.

Do you get the same problem if you Windows start in safe mode?

You can use msconfig to disable most autostart entries.

Start, type msconfig and press enter. Go to the services tab and mark hide all Microsoft services, (Make sure you did not miss the previous step, your machine will likely not boot)press disable all. Go to the startup tab and press disable all. Click Ok and reboot. Does it work better now?

If it's working better then you might need to try out the autostart apps one by one to figure out which one is causing your issue.

If it's not working any better I would suggest checking for new drivers and uninstall any antivirus/firewall software since you cannot disable them reliably.

share|improve this answer
    
"Make sure you did not miss the previous step, your machine will likely not boot)" Totally false. Windows does not let you deactivate crutial - essential- services through msconfig. –  Lorenzo Von Matterhorn Dec 17 '12 at 19:31

Install Process Explorer, and make sure it runs at startup. It keeps a history of recent processor usage, and tells you which programs were taxing the CPU most at any given time (mouse over the CPU history and a tooltip appears identifying the CPU hog at that time).

alt text

share|improve this answer

Autoruns (from Sysinternals) can be an eye-opener too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.