Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can root login be enabled in Ubuntu 9.10?

share|improve this question

migrated from stackoverflow.com Mar 5 '10 at 17:13

This question came from our site for professional and enthusiast programmers.

1  
Yes, it's bad practice. So anyway, what's the answer? –  Nathaniel Mar 5 '10 at 19:51
add comment

7 Answers 7

If you already have the root user enabled and are trying to login at the gdm login screen, try checking the file /etc/gdm/custom.conf for the AllowRoot property. It needs to be set to true.

[security]
AllowRoot=true

You may have to add those lines to the file. Restart gdm and you should be able to login as the root user.

Also, there is a AllowRemoteRoot property if you are trying to login as root to the machine from another machine.

share|improve this answer
    
If you just need a root file manager you can run one with the command "sudo nautilus" –  Chris Nava Mar 5 '10 at 17:50
    
Also if you have SSHd operating for remote access (it isn't installed by default for desktop setups but you are likely to have it if you are running an Ubuntu based server). Open up /etc/ssh/sshd_config and set "PermitRootLogin" to "yes", or "without-password" to force key-based authentication for root (even if you allow password based auth for other users). –  David Spillett Mar 8 '10 at 9:57
    
I'm happy to see there is a solution to do this under Linux, but I also agree this should be avoided. I use Ubuntu for a long time now, since version 6.06, and I nvever had to login as root. Always used sudo or gksudo. And gksudo was mostly required for some removable medias that I could not write to, for some strange permissions problems. gksudo nautilus /media/disk solved my problem. –  jfmessier Mar 8 '10 at 13:19
add comment

I really doubt that you need to do this. Just use gksudo anyprogram to run it as root.

And, if you really, really want to run a GUI as root, you can just do (in a text terminal - Alt-1 - Alt-6):

> sudo /etc/init.d/gdm stop
> su - (if you already have enabled the root login)
# startx

I hardly see any reason to play with the gdm config, as what you are asking for should not be a regular situation, as whenever you need it, you can put the extra effort.

share|improve this answer
add comment

Set root password, it will be enabled. Run this in terminal,

passwd root
or add sudo if needed.

share|improve this answer
add comment
$ sudo su
# passwd

Will do the trick, but you shouldn't do it.

share|improve this answer
add comment

This will work

$ sudo -i
# passwd
Enter new UNIX password: 
Retype new UNIX password: 
passwd: password updated successfully

Enter password in the field and it will successfully change it.

share|improve this answer
add comment

If you want to go 'su' like in debian, you can 'sudo su'.

share|improve this answer
add comment

login as other in your ubuntu login screen with username "root" and password that you have set for root. once you logged in, go to system/administration/users and groups and delete your username that you have created while installing ubuntu 9.10. type this in your terminal "sudo reboot" then you was done.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.